diff mbox series

[bug#46415] gnu: OpenLDAP: Update to 2.4.57 [security fixes].

Message ID aa7cb6c0f1e068d21b119414cbad1e504254e98c.1612915563.git.leo@famulari.name
State Accepted
Headers show
Series [bug#46415] gnu: OpenLDAP: Update to 2.4.57 [security fixes]. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Feb. 10, 2021, 12:06 a.m. UTC
Fixes CVE-2020-{36221,36222,36223,36224,36225,36226,36226,36228,36229,36230}.

* gnu/packages/openldap.scm (openldap-2.4.57): New variable.
(openldap)[replacement]: New field.
---
 gnu/packages/openldap.scm | 24 +++++++++++++++++++++++-
 1 file changed, 23 insertions(+), 1 deletion(-)

Comments

Efraim Flashner Feb. 11, 2021, 11:15 a.m. UTC | #1
I assume you've tested it out? Looks good to me. I assume there's no way
to inherit the list of URLs from openldap to openldap/fixed and still
have it download the correct version.
Leo Famulari Feb. 11, 2021, 7:18 p.m. UTC | #2
On Thu, Feb 11, 2021 at 01:15:08PM +0200, Efraim Flashner wrote:
> I assume you've tested it out? Looks good to me. I assume there's no way
> to inherit the list of URLs from openldap to openldap/fixed and still
> have it download the correct version.

I tested that it builds but I don't have a way to test LDAP
functionality.
Efraim Flashner Feb. 11, 2021, 7:21 p.m. UTC | #3
On Thu, Feb 11, 2021 at 02:18:57PM -0500, Leo Famulari wrote:
> On Thu, Feb 11, 2021 at 01:15:08PM +0200, Efraim Flashner wrote:
> > I assume you've tested it out? Looks good to me. I assume there's no way
> > to inherit the list of URLs from openldap to openldap/fixed and still
> > have it download the correct version.
> 
> I tested that it builds but I don't have a way to test LDAP
> functionality.

I meant I assumed you tested it built and grafted correctly, as best as
we can tell.
Leo Famulari Feb. 11, 2021, 8:03 p.m. UTC | #4
On Thu, Feb 11, 2021 at 09:21:14PM +0200, Efraim Flashner wrote:
> On Thu, Feb 11, 2021 at 02:18:57PM -0500, Leo Famulari wrote:
> > On Thu, Feb 11, 2021 at 01:15:08PM +0200, Efraim Flashner wrote:
> > > I assume you've tested it out? Looks good to me. I assume there's no way
> > > to inherit the list of URLs from openldap to openldap/fixed and still
> > > have it download the correct version.
> > 
> > I tested that it builds but I don't have a way to test LDAP
> > functionality.
> 
> I meant I assumed you tested it built and grafted correctly, as best as
> we can tell.

Yeah. Thanks for review! Pushed as a18492118cc73bee9a2e6424363e3e072572f52e
diff mbox series

Patch

diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index fb917882e7..c23a9f6c25 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -1,7 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014, 2015, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -61,6 +61,7 @@ 
 (define-public openldap
   (package
    (name "openldap")
+   (replacement openldap-2.4.57)
    (version "2.4.50")
    (source (origin
              (method url-fetch)
@@ -125,6 +126,27 @@ 
    (license openldap2.8)
    (home-page "https://www.openldap.org/")))
 
+(define-public openldap-2.4.57
+  (package
+    (inherit openldap)
+    (version "2.4.57")
+    (source (origin
+              (method url-fetch)
+              ;; See <http://www.openldap.org/software/download/> for a list of
+              ;; mirrors.
+              (uri (list (string-append
+                          "ftp://mirror.switch.ch/mirror/OpenLDAP/"
+                          "openldap-release/openldap-" version ".tgz")
+                         (string-append
+                          "https://www.openldap.org/software/download/OpenLDAP/"
+                          "openldap-release/openldap-" version ".tgz")
+                         (string-append
+                          "ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/"
+                          "openldap-release/openldap-" version ".tgz")))
+              (sha256
+               (base32
+                "0nmlyqhc52v24b4awh914sczmvxbazgq2cnlycvb9dgcwvhlgfn7"))))))
+
 (define-public nss-pam-ldapd
   (package
     (name "nss-pam-ldapd")