diff mbox series

[bug#56576,v3,1/3] gnu: Add markdeep.

Message ID aa7483564f086c1dd70c428c0156ef8355e76a61.1712184392.git.cdo@mutix.org
State New
Headers show
Series [bug#56576,v3,1/3] gnu: Add markdeep. | expand

Commit Message

Christina O'Donnell April 3, 2024, 10:46 p.m. UTC
* gnu packages/documentation.scm (markdeep): New variable.

Change-Id: I34303377f50740ba357c1bb299c9434079a6e23d
---
 gnu/packages/documentation.scm | 65 ++++++++++++++++++++++++++++++++++
 1 file changed, 65 insertions(+)

Hi,

I've gone through these patches, making the changes that Maxime listed
and that came up from `guix lint`. I've added the additional package
markdeep, which is a css/javascript rendering library needed for stddoc.

I checked these very carefully, but I'm new to this so it's likely that
I've made at least a few mistakes. Everything appears to be working as
far as I've tested it. I had anything to test nuklear with, so I'm
taking that part on faith.

Let me know whether there's anything that I could change or do better
for next time. 

Kind regards,
Christina


base-commit: 4d994f98a49e1a6e58b9b0b512a05efc1c431a50

Comments

Ludovic Courtès April 11, 2024, 10:37 a.m. UTC | #1
Hi Christina,

Christina O'Donnell <cdo@mutix.org> skribis:

> * gnu packages/documentation.scm (markdeep): New variable.
>
> Change-Id: I34303377f50740ba357c1bb299c9434079a6e23d
> ---
>  gnu/packages/documentation.scm | 65 ++++++++++++++++++++++++++++++++++
>  1 file changed, 65 insertions(+)
>
> Hi,
>
> I've gone through these patches, making the changes that Maxime listed
> and that came up from `guix lint`. I've added the additional package
> markdeep, which is a css/javascript rendering library needed for stddoc.
>
> I checked these very carefully, but I'm new to this so it's likely that
> I've made at least a few mistakes. Everything appears to be working as
> far as I've tested it. I had anything to test nuklear with, so I'm
> taking that part on faith.
>
> Let me know whether there's anything that I could change or do better
> for next time. 

It’s perfect!  There was a tiny indentation issue for phases in
‘markdeep’ but the rest looks good to me.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 83c4313bd7..da930c7304 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -37,6 +37,7 @@  (define-module (gnu packages documentation)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
   #:use-module (guix build-system qt)
@@ -57,11 +58,13 @@  (define-module (gnu packages documentation)
   #:use-module (gnu packages graphviz)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages javascript)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages sphinx)
+  #:use-module (gnu packages uglifyjs)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
@@ -453,3 +456,65 @@  (define-public zeal
       (description "Zeal is a simple offline documentation browser
 inspired by Dash.")
       (license license:gpl3+))))
+
+(define-public markdeep
+  (package
+    (name "markdeep")
+    (version "1.16")
+    (home-page "https://casual-effects.com/markdeep/")
+    (source
+     (origin (method git-fetch)
+             (uri (git-reference
+                   (url "https://github.com/morgan3d/markdeep")
+                   (commit (string-append "v0" version))))
+             (sha256
+              (base32 "05bvw3993xh1260ckclwk4jw38hvgiff0b2940ryhbhz0p1k41l8"))))
+    (build-system copy-build-system)
+    (arguments
+     (list #:modules '((guix build utils)
+                       (guix build copy-build-system)
+                       (ice-9 popen))
+           #:install-plan ''(("." "/share/markdeep/"))
+           #:phases
+           #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-urls
+            (lambda _
+              (for-each (lambda (filename)
+
+                          (substitute* filename
+                            ;; Don't include a reference to the remote version.
+                            (("<script src=\"https://casual-effects\\.com/\
+markdeep/latest/markdeep\\.min\\.js\\?\"></script>")
+                             "")
+                            (("MATHJAX_URL = .*$")
+                             ;; Use our local copy of mathjax
+                             (string-append "MATHJAX_URL = 'file://" #$js-mathjax
+                                            "/share/javascript/es5/tex-mml-chtml.js'"))))
+                        (find-files "." (lambda (file stat)
+                                          (string-suffix? ".js" file))))))
+          (add-before 'install 'minify
+            (lambda _
+              (for-each (lambda (filename)
+                          (let ((minified-filename
+                                 (string-append (string-drop-right filename 3)
+                                                ".min.js")))
+                          (format #t "~a -> ~a~%" filename minified-filename)
+                          (let ((minified (open-pipe* OPEN_READ "uglifyjs" filename)))
+                            (call-with-output-file minified-filename
+                              (lambda (port)
+                                (dump-port minified port)))
+
+                            (let ((exit (close-pipe minified)))
+                              (unless (zero? exit)
+                                (error "uglifyjs failed" exit))))))
+                        (find-files "latest"
+                                    (lambda (path stat)
+                                      (and (string-suffix? ".js" path)
+                                           (not (string-suffix? ".min.js" path)))))))))))
+    (inputs (list js-mathjax))
+    (native-inputs (list uglifyjs))
+    (synopsis "Tool for displaying markdown documents in a web-browser")
+    (description "Markdeep is a technology for writing plain text documents that can
+be displayed in any web browser, whether local or remote.  It supports diagrams,
+calendars, equations, and other features as extensions of Markdown syntax.")
+    (license license:bsd-2)))