diff mbox series

[bug#72107,3/5] gnu: Add ocaml-domain-schims.

Message ID aa4668c8003a4954a9b62a997a6d232d9524beca.1720956786.git.benjamin@uvy.fr
State New
Headers show
Series gnu: ocaml-eio: Update to 0.12. | expand

Commit Message

Benjamin July 14, 2024, 11:49 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-domain-schims): New variable.

Change-Id: Ifbf8ade84658862a187f165a1bf7abe17ee1ecb7
---
 gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a6fb5af138..fdeec8f2a1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3156,6 +3156,30 @@  (define-public ocaml-thread-table
 for associating thread specific state with threads within a domain.")
     (license license:isc)))
 
+(define-public ocaml-domain-schims
+  (package
+    (name "ocaml-domain-schims")
+    (version "0.1.0")
+    (home-page "https://gitlab.com/gasche/domain-shims")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256 (base32
+                "0mxvzhxgcrvv0l99i4blag52v7g1knycwsh1xv9vkmh0rpwb147z"))))
+    (build-system dune-build-system)
+    (arguments `(#:package "domain_shims"))
+    (native-inputs (list))
+    (synopsis "A self-contained implementation of the Domain module for OCaml 4.")
+    (description "Domain is a new module of the OCaml 5 standard library that exposes
+the Multicore OCaml runtime's ability to run OCaml computations in parallel.
+With domain-shims, you can compile run code that was written for
+OCaml 5 using the Domain module under OCaml 4")
+    (license license:expat)))
+
 (define ocaml-eio
   (package
     (name "ocaml-eio")