diff mbox series

[bug#47958] gnu: Add emacs-shell-command+.

Message ID aa413f6fdabe31dc8ea94a5236edf759d9f929e0.1619123476.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#47958] gnu: Add emacs-shell-command+. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 22, 2021, 8:35 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-shell-command+): New variable.
---
I would prefer to avoid ELPA URLs because of issues with
reproducibility[1], but I wasn’t able to find any references to the
upstream Git repository.

[1]: https://yhetil.org/guix-bugs/1614603812.pcr83awkcn.jorsn@jorsn.eu

 gnu/packages/emacs-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)


base-commit: 5a0098e152c8888d4eea86593765a8bf393de5c4

Comments

Nicolas Goaziou April 23, 2021, 9:12 a.m. UTC | #1
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

> * gnu/packages/emacs-xyz.scm (emacs-shell-command+): New variable.

Thank you.
> ---
> I would prefer to avoid ELPA URLs because of issues with
> reproducibility[1], but I wasn’t able to find any references to the
> upstream Git repository.

Hopefully, at some point, we will fix this bug.

> +    (synopsis "An extended shell-command")

Synopsis cannot start with "An". "guix lint" should catch this.

Applied.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c7cce1563d..d590bdd98f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26974,6 +26974,25 @@  Features:
 @end itemize\n")
     (license license:gpl3+)))
 
+(define-public emacs-shell-command+
+  (package
+    (name "emacs-shell-command+")
+    (version "2.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://elpa.gnu.org/packages/"
+                                  "shell-command+-" version ".tar"))
+              (sha256
+               (base32 "1jyrnv89989bi03m5h8dj0cllsw3rvyxkiyfrh9v6gpxjwfy8lmq"))))
+    (build-system emacs-build-system)
+    (home-page "http://elpa.gnu.org/packages/shell-command+.html")
+    (synopsis "An extended shell-command")
+    (description "@code{shell-command+} is a @code{shell-command} substitue,
+that extends the regular Emacs command with several features.  You can for
+example count all the lines in a buffer with @code{> wc -l}, or delete all
+lower case letters in the selected region with @code{| tr -d a-z}.")
+    (license license:gpl3+)))
+
 (define-public emacs-shell-pop
   (let ((commit "4b4394037940a890a313d715d203d9ead2d156a6")
         (revision "0"))