diff mbox series

[bug#71076,06/81] gnu: Add rust-jsonwebtoken-9.

Message ID aa39473906720c12732145f76221ffc8d431725f.1716193122.git.herman@rimm.ee
State New
Headers show
Series Add matrix-conduit and ruma-0.10. | expand

Commit Message

Herman Rimm May 20, 2024, 8:58 a.m. UTC
* gnu/packages/crates-web.scm (rust-jsonwebtoken-9): Add variable.
(rust-jsonwebtoken-7): Inherit from rust-jsonwebtoken-9.

Change-Id: Id61aacdb553447da7ba5a4484f607efcc748fbe6
---
 gnu/packages/crates-web.scm | 38 +++++++++++++++++++++++++++++++------
 1 file changed, 32 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index f21f0c3398..1e0e0fc54c 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -4227,8 +4227,39 @@  (define-public rust-json5-0.4
 which speaks Serde.")
     (license license:isc)))
 
+(define-public rust-jsonwebtoken-9
+  (package
+    (name "rust-jsonwebtoken")
+    (version "9.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "jsonwebtoken" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0gqr13c9fjd4zb2lqzhgi4xwq0rfnk8a47jzjis1w1957lci1bmr"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list
+      #:cargo-inputs (list rust-base64-0.21
+                           rust-js-sys-0.3
+                           rust-pem-3
+                           rust-ring-0.17
+                           rust-serde-1
+                           rust-serde-json-1
+                           rust-simple-asn1-0.6)
+      #:cargo-development-inputs (list rust-criterion-0.4 rust-time-0.3
+                                       rust-wasm-bindgen-test-0.3)))
+    (home-page "https://github.com/Keats/jsonwebtoken")
+    (synopsis "Create and decode JWTs in a strongly typed way")
+    (description
+     "This package provides a strongly typed way to create and decode
+JWTs.")
+    (license license:expat)))
+
 (define-public rust-jsonwebtoken-7
   (package
+    (inherit rust-jsonwebtoken-9)
     (name "rust-jsonwebtoken")
     (version "7.2.0")
     (source
@@ -4238,7 +4269,6 @@  (define-public rust-jsonwebtoken-7
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "0ciz205wcjcn7n6i871zz5xlbzk863b0ybgiqi7li9ipwhawraxg"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs (("rust-base64" ,rust-base64-0.12)
                        ("rust-pem" ,rust-pem-0.8)
@@ -4246,11 +4276,7 @@  (define-public rust-jsonwebtoken-7
                        ("rust-serde" ,rust-serde-1)
                        ("rust-serde-json" ,rust-serde-json-1)
                        ("rust-simple-asn1" ,rust-simple-asn1-0.4))
-       #:cargo-development-inputs (("rust-chrono" ,rust-chrono-0.4))))
-    (home-page "https://github.com/Keats/jsonwebtoken")
-    (synopsis "Create and decode JWTs in a strongly typed way")
-    (description "Create and decode JWTs in a strongly typed way.")
-    (license license:expat)))
+       #:cargo-development-inputs (("rust-chrono" ,rust-chrono-0.4))))))
 
 (define-public rust-mas-http-0.7
   (package