diff mbox series

[bug#73298,1/2] gnu: coq-mathcomp-bigenough: Use new style.

Message ID aa2f8b5a506d2558c2a1d2c0884bec9d2cfd012c.1726500406.git.jean@foundation.xyz
State New
Headers show
Series gnu: coq-mathcomp-bigenough: Use native-inputs. | expand

Commit Message

Jean-Pierre De Jesus Diaz Sept. 16, 2024, 3:29 p.m. UTC
* gnu/packages/coq.scm (coq-mathcomp-bigenough) [arguments]: Use new
style and remove uneeded make flags.

Change-Id: I11a6350a10cedd682cf598ecb8660b63a12aa00d
---
 gnu/packages/coq.scm | 25 ++++++++++---------------
 1 file changed, 10 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 31d1e8d51d..166657fdd1 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -753,21 +753,16 @@  (define-public coq-mathcomp-bigenough
                 "02f4dv4rz72liciwxb2k7acwx6lgqz4381mqyq5854p3nbyn06aw"))))
     (build-system gnu-build-system)
     (arguments
-     `(;; No references to tests in Makefile.common.
-       ;; It doesn't appear as though tests will be included
-       ;; by the packaged project in the future.
-       #:tests? #f
-       #:make-flags ,#~(list (string-append "COQBIN="
-                                            #$(this-package-input "coq")
-                                            "/bin/")
-                             (string-append "COQMF_COQLIB="
-                                            (assoc-ref %outputs "out")
-                                            "/lib/ocaml/site-lib/coq")
-                             (string-append "COQLIBINSTALL="
-                                            (assoc-ref %outputs "out")
-                                            "/lib/coq/user-contrib"))
-       #:phases (modify-phases %standard-phases
-                  (delete 'configure))))
+     (list ;; No references to tests in Makefile.common.
+           ;; It doesn't appear as though tests will be included
+           ;; by the packaged project in the future.
+           #:tests? #f
+           #:make-flags
+           #~(list (string-append "COQLIBINSTALL=" #$output
+                                  "/lib/coq/user-contrib"))
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure))))
     (propagated-inputs (list coq coq-mathcomp which))
     (home-page "https://math-comp.github.io/")
     (synopsis "Small library to do epsilon - N reasoning")