diff mbox series

[bug#69924,46/49] gnu: Add python-cmyt.

Message ID aa1505cad599cb7544260ecb565f47d048368be9.1710967275.git.sharlatanus@gmail.com
State New
Headers show
Series gnu: Astronomy 2024/02 updates. | expand

Commit Message

Sharlatan Hellseher March 20, 2024, 10:28 p.m. UTC
* gnu/packages/python-xyz.scm (python-cmyt): New variable.

Change-Id: I45caa38fc391fe7890f87f41b18d3cfa8da07c80
---
 gnu/packages/astronomy.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a898b98515..14b2c37343 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2056,6 +2056,31 @@  (define-public python-cdflib
 @end itemize")
     (license license:expat)))
 
+(define-public python-cmyt
+  (package
+    (name "python-cmyt")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "cmyt" version))
+       (sha256
+        (base32 "1zabmckr1z637pfqqvlkj0asfqqvx2x92163dby8x0c8yiqgdvjb"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-colorspacious python-pytest python-pytest-mpl))
+    (propagated-inputs
+     (list python-matplotlib python-numpy))
+    (home-page "https://yt-project.org/")
+    (synopsis "Matplotlib colormaps from the yt project")
+    (description
+     "This package provides a range of colormaps designed for scientific
+use with Matplotlib.  It includes perceptually uniform sequential colormaps such
+as @code{abre}, @code{dusk}, @code{kepl}, and @code{octarine}, as well as
+monochromatic sequential colormaps like @code{blue}, @code{green}, and
+@code{red}, and others (@code{algae}, @code{pastel}, and @code{xray}).")
+    (license license:bsd-3)))
+
 (define-public python-crds
   (package
     (name "python-crds")