diff mbox series

[bug#50657,v2] gnu: Add vpn-slice.

Message ID aYDmel23x5oNh6gRBLyPkVFB2bWi-Majf_BM80ce6eg4ilIZpNs4vpLe8vaEX933-z6fbN0KbGNDBGjCDP2OsowqBHSdXRNXBeJaPIiAyvk=@protonmail.com
State New
Headers show
Series [bug#50657,v2] gnu: Add vpn-slice. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Sept. 27, 2021, 10:32 p.m. UTC
Hi Xinglu,

I checked the /etc/hosts and seems that on Guix System there aren't symlink to the /gnu/store.

$ readlink -f /etc/hostname
/etc/hostname

--8<---------------cut here---------------start------------->8---

* gnu/packages/vpn.scm (vpn-slice): New variable.

--
2.32.0

Comments

phodina Dec. 3, 2021, 3:35 p.m. UTC | #1
ping
Nicolas Goaziou Dec. 5, 2021, 11:14 a.m. UTC | #2
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

> I checked the /etc/hosts and seems that on Guix System there aren't symlink to the /gnu/store.
>
> $ readlink -f /etc/hostname
> /etc/hostname

But it is read-only, isn't it? If so, how can the program do its stuff,
since it is supposed to modify the file?

> +        (sha256
> +          (base32
> +            "0lv3g1bq6ssz6fn6zlzn12dahc4d7nf7kjwxsnb5d7gdrfp36lbx"))))

Nitpick: Hash string should be on the same line as base32

> +    (description "This package allows you to minimize your contact with
> +an intrusive VPN --- split your traffic between the VPN tunnel and your normal
> +network interfaces")

Nitpick: I think English does not add spaces between "---".

> +    (license license:gpl3)))

You forgot to change the license, as suggested by Xinglu Chen.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 330a3271b4..cf79bc07f8 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Domagoj Stolfa <ds815@gmx.com>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Petr Hodina  <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -432,6 +433,29 @@  file for more details.")
            ;; src/libstrongswan/plugins/des/des_crypter.c
            license:bsd-4))))

+(define-public vpn-slice
+  (package
+    (name "vpn-slice")
+    (version "0.15")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "vpn-slice" version))
+        (sha256
+          (base32
+            "0lv3g1bq6ssz6fn6zlzn12dahc4d7nf7kjwxsnb5d7gdrfp36lbx"))))
+    (build-system python-build-system)
+    (native-inputs `(("python-pytest" ,python-pytest)))
+    (propagated-inputs
+      `(("python-dnspython" ,python-dnspython)
+        ("python-setproctitle" ,python-setproctitle)))
+    (home-page "https://github.com/dlenski/vpn-slice")
+    (synopsis "Easy and secure split-tunnel VPN setup")
+    (description "This package allows you to minimize your contact with
+an intrusive VPN --- split your traffic between the VPN tunnel and your normal
+network interfaces")
+    (license license:gpl3)))
+
 (define-public vpnc
   (package
    (name "vpnc")