[bug#78182,v1] gnu: python-h5py: Update to 3.13.0.

Message ID aBNLgWKekXBtJsGn@kernelpanicroom
State New
Headers
Series [bug#78182,v1] gnu: python-h5py: Update to 3.13.0. |

Commit Message

Jakob Kirsch May 1, 2025, 10:22 a.m. UTC
  * gnu/packages/python-xyz.scm (python-h5py): Update to 3.13.0.

Change-Id: I312240bb0e84cbb18dc678d5e7aa6e8c18c09cfb
---
 gnu/packages/python-xyz.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)


base-commit: c8efb51982c3099a2a14b8412b2e258c522e94c5
  

Comments

Sharlatan Hellseher May 1, 2025, 3:57 p.m. UTC | #1
Hi,

It was updated in
https://git.savannah.gnu.org/cgit/guix.git/commit/?id=93f4a0db0675fe847e1fb6bcd740393e0ddb4ceb

Closing as not applied.

Thanks.

VCS: https://github.incerto.xyz/; https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5

… наш разум - превосходная объяснительная машина которая способна найти
смысл почти в чем угодно, истолковать любой феномен, но совершенно не в
состоянии принять мысль о непредсказуемости.
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9691c48781..859bdc57bb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3872,20 +3872,23 @@  (define-public python-h5netcdf
 (define-public python-h5py
   (package
     (name "python-h5py")
-    (version "3.8.0")
+    (version "3.13.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "h5py" version))
        (sha256
-        (base32 "0pyr6z4h2xqbp49yx2i1401gl6yqh03h771zslwcy0201hpxiskg"))))
+        (base32 "1hq5f5mnkv2138xsq7k7qncf6b7zc0cmm2fhhpd2603j31jy8w0q"))))
     (build-system python-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
                   (add-after 'unpack 'fix-hdf5-paths
                     (lambda* (#:key inputs #:allow-other-keys)
                       (setenv "HDF5_DIR"
-                              (assoc-ref inputs "hdf5")))))))
+                              (assoc-ref inputs "hdf5"))))
+                  (add-after 'unpack 'disable-broken-test
+                    ; see https://github.com/h5py/h5py/blob/92ec254bf736127b8699e29090481bf5c78bbd49/h5py/tests/test_file.py#L227
+                    (lambda _ (substitute* "h5py/tests/test_file.py" (("\"\"\"Page buffer size must be greater than file space page size.\"\"\"") "return")))))))
     (propagated-inputs (list python-six python-numpy))
     (inputs (list hdf5))
     (native-inputs (list pkg-config python-cython python-ipython