diff mbox series

[bug#64181] gnu: mmg: Update to 5.7.1.

Message ID a9e4247c2b089c1a7dda47d9650ed523ed820bb9.1687225214.git.paul@apatience.com
State New
Headers show
Series [bug#64181] gnu: mmg: Update to 5.7.1. | expand

Commit Message

Paul A. Patience June 20, 2023, 1:40 a.m. UTC
* gnu/packages/graphics.scm (mmg): Update to 5.7.1.
[arguments]<#:configure-flags>: Set -DCMAKE_INSTALL_MANDIR. Add
-DBUILD_DOC=ON and -DUSE_SCOTCH=ON, the defaults of which changed since
the last version. Scotch is still autodetected, but explicitly enabling
it causes the configuration to fail if it is not found.
<#:phases>: Do not copy the manual pages, because the build now does it.
---
 gnu/packages/graphics.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)


base-commit: d884fc9e2efecfba09af4694f5a13ad7fc6f704f
prerequisite-patch-id: 52027b181c066ac91bc56fc0af511a34f3516651

Comments

Paul A. Patience June 20, 2023, 2:19 p.m. UTC | #1
Sorry, I didn't realize the prerequisite-patch-id field was being added to the patch.
Please disregard it, it is unnecessary.

On Monday, June 19th, 2023 at 9:40 PM, Paul A. Patience <paul@apatience.com> wrote:
> base-commit: d884fc9e2efecfba09af4694f5a13ad7fc6f704f
> prerequisite-patch-id: 52027b181c066ac91bc56fc0af511a34f3516651

Best regards,
Paul
Ludovic Courtès June 25, 2023, 8:59 p.m. UTC | #2
Hi Paul,

"Paul A. Patience" <paul@apatience.com> skribis:

> * gnu/packages/graphics.scm (mmg): Update to 5.7.1.
> [arguments]<#:configure-flags>: Set -DCMAKE_INSTALL_MANDIR. Add
> -DBUILD_DOC=ON and -DUSE_SCOTCH=ON, the defaults of which changed since
> the last version. Scotch is still autodetected, but explicitly enabling
> it causes the configuration to fail if it is not found.
> <#:phases>: Do not copy the manual pages, because the build now does it.

Applied, thanks!

Ludo’.
Christopher Baines June 26, 2023, 8:53 a.m. UTC | #3
Ludovic Courtès <ludovic.courtes@inria.fr> writes:

> Hi Paul,
>
> "Paul A. Patience" <paul@apatience.com> skribis:
>
>> * gnu/packages/graphics.scm (mmg): Update to 5.7.1.
>> [arguments]<#:configure-flags>: Set -DCMAKE_INSTALL_MANDIR. Add
>> -DBUILD_DOC=ON and -DUSE_SCOTCH=ON, the defaults of which changed since
>> the last version. Scotch is still autodetected, but explicitly enabling
>> it causes the configuration to fail if it is not found.
>> <#:phases>: Do not copy the manual pages, because the build now does it.
>
> Applied, thanks!

Marking as done.
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 3a65b96919..2a7a86d9a0 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2395,7 +2395,7 @@  (define-public discregrid
 (define-public mmg
   (package
     (name "mmg")
-    (version "5.6.0")
+    (version "5.7.1")
     (source
      (origin
        (method git-fetch)
@@ -2404,7 +2404,7 @@  (define-public mmg
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "173biz5skbwg27i5w6layg7mydjzv3rmi1ywhra4rx9rjf5c0cc5"))))
+        (base32 "0skb7yzsw6y44zp9gb729i5xks7qd97nvn3z6jhz4jksqksx7lz0"))))
     (build-system cmake-build-system)
     (outputs '("out" "lib" "doc"))
     (arguments
@@ -2414,11 +2414,14 @@  (define-public mmg
                    ;; The build doesn't honor -DCMAKE_INSTALL_BINDIR, hence
                    ;; the adjust-bindir phase.
                    ;;(string-append "-DCMAKE_INSTALL_BINDIR=" #$output "/bin")
+                   (string-append "-DCMAKE_INSTALL_MANDIR=" #$output "/share/man")
                    "-DBUILD_SHARED_LIBS=ON"
+                   "-DBUILD_DOC=ON"
                    "-DBUILD_TESTING=ON"
                    ;; The longer tests are for continuous integration and
                    ;; depend on input data which must be downloaded.
                    "-DONLY_VERY_SHORT_TESTS=ON"
+                   "-DUSE_SCOTCH=ON"
                    ;; TODO: Add Elas (from
                    ;; https://github.com/ISCDtoolbox/LinearElasticity).
                    "-DUSE_ELAS=OFF"
@@ -2443,9 +2446,6 @@  (define-public mmg
                    (invoke "make" "doc")))
                (add-after 'install 'install-doc
                  (lambda _
-                   (copy-recursively
-                    "../source/doc/man" (string-append #$output
-                                                       "/share/man/man1"))
                    (copy-recursively
                     "doc" (string-append #$output:doc "/share/doc/"
                                          #$name "-" #$version))))