diff mbox series

[bug#61793] gnu: mruby: Update to 3.2.0.

Message ID a9bd3ed6-fcda-f169-87ce-baba8cf0db2c@gorski.stream
State New
Headers show
Series [bug#61793] gnu: mruby: Update to 3.2.0. | expand

Commit Message

Yovan Naumovski Feb. 25, 2023, 8:17 p.m. UTC
Hi,

here's a patch that updates mruby to 3.2.0. I removed two substitutions 
from the 'disable-broken-tests, the tests seem to pass without them.

Best regards,

Yovan.

Comments

Christopher Baines March 14, 2023, 10:44 a.m. UTC | #1
Yovan Naumovski via Guix-patches via <guix-patches@gnu.org> writes:

> Hi,
>
> here's a patch that updates mruby to 3.2.0. I removed two
> substitutions from the 'disable-broken-tests, the tests seem to pass
> without them.
>
> Best regards,
>
> Yovan.
>
> [2. text/x-patch; 0001-gnu-packages-ruby.scm-mruby-Update-to-3.2.0.patch]...

Thanks Yovan, pushed to master as
476e1b270e657a82ef3a8d253d694d07a766cde4.

Chris
diff mbox series

Patch

* gnu/packages/ruby.scm (mruby): Update to 3.2.0.
 [arguments]: Remove unnecessary substitutions in the 'disable-broken-tests
 phase.
 [description]: Update.
---
 gnu/packages/ruby.scm | 15 ++++++---------
 1 file changed, 6 insertions(+), 9 deletions(-)

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2e8d4038de..8f38389719 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -31,6 +31,7 @@ 
 ;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
 ;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
 ;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
+;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -259,7 +260,7 @@  (define-public ruby ruby-2.7)
 (define-public mruby
   (package
     (name "mruby")
-    (version "2.1.2")
+    (version "3.2.0")
     (source
      (origin
        (method git-fetch)
@@ -269,7 +270,7 @@  (define-public mruby
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0fhfv8pi7i8jn2vgk2n2rjnbnfa12nhj514v8i4k353n7q4pmkh3"))))
+         "0c0scaqbnywrd9z1z4rnnj345rjc3vbklszm0rc6y6rzx1cxnsij"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
@@ -287,13 +288,9 @@  (define-public mruby
              (substitute* "mrbgems/mruby-io/test/io.rb"
                (("assert\\('IO.popen.+$" m)
                 (string-append m "skip \"Hangs in the Guix build environment\"\n"))
-               (("assert\\('IO#isatty.+$" m)
-                (string-append m "skip \"Disable for Guix; there is no /dev/tty\"\n"))
                ;; This one is really weird.  The *expected* output is all wrong.
                (("assert\\('`cmd`.*" m)
-                (string-append m "skip \"Disable for Guix\"\n"))
-               (("echo foo")
-                (string-append (which "echo") " foo")))
+                (string-append m "skip \"Disable for Guix\"\n")))
              #t))
          ;; There is no install target
          (replace 'install
@@ -311,8 +308,8 @@  (define-public mruby
     (home-page "https://github.com/mruby/mruby")
     (synopsis "Lightweight Ruby")
     (description "mruby is the lightweight implementation of the Ruby
-language.  Its syntax is Ruby 1.9 compatible.  mruby can be linked and
-embedded within your application.")
+language.  Its syntax is Ruby 3.x compatible except for pattern
+matching.  mruby can be linked and embedded within your application.")
     (license license:expat)))
 
 (define-public ruby-commander
-- 
2.39.1