diff mbox series

[bug#54457,PATCHv3,6/9] gnu: Add libnetfilter-acct

Message ID a97b06d9-3caa-3bb7-2152-f365c656bbff@gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

fesoj000 March 26, 2022, 11:34 p.m. UTC
* gnu/packages/linux.scm (libnetfilter-acct): New variable.
---
  gnu/packages/linux.scm | 33 +++++++++++++++++++++++++++++++++
  1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0d3a69b17c..4956f9dc6c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7426,6 +7426,39 @@  (define-public conntrack-tools
     (supported-systems (filter target-linux? %supported-systems))
     (license license:gpl2+)))
  
+(define-public libnetfilter-acct
+  (package
+   (name "libnetfilter-acct")
+   (version "1.0.3")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "https://netfilter.org/projects/"
+                         "libnetfilter_acct/files/"
+                         "libnetfilter_acct-"
+                         version ".tar.bz2"))
+     (sha256
+      (base32
+       "06lsjndgfjsgfjr43px2n2wk3nr7whz6r405mks3887y7vpwwl22"))))
+   (build-system gnu-build-system)
+   (native-inputs (list pkg-config))
+   (inputs (list libmnl))
+   (synopsis "Library providing interface to extended accounting infrastructure.")
+   (description "libnetfilter_acct is the userspace library providing interface
+to extended accounting infrastructure.
+@enumerate
+@item
+creating accounting objects
+@item
+retrieving accounting objects (and atomically set to zero)
+@item
+deleting accounting objects
+@end enumerate
+For the nfnetlink_acct subsystem.")
+   (home-page "https://netfilter.org/projects/libnetfilter_acct/index.html")
+   (supported-systems (filter target-linux? %supported-systems))
+   (license license:lgpl2.1+)))
+
  (define-public proot
    (package
      (name "proot")