diff mbox series

[bug#38480] gnu: Add lolcat

Message ID a9087ff071bae8a10c948a32b8d5cef08aa6bc6a.camel@student.tugraz.at
State Accepted
Headers show
Series [bug#38480] gnu: Add lolcat | expand

Commit Message

Leo Prikler Dec. 15, 2019, 12:10 a.m. UTC
Hello!

Am Sonntag, den 15.12.2019, 00:28 +0100 schrieb Ludovic Courtès:
> Hello!
> 
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
> 
> > From: Leo Prikler <leo.prikler@student.tugraz.at>
> > Date: Wed,  4 Dec 2019 02:46:44 +0100
> > Subject: [PATCH] gnu: Add lolcat
> > 
> > * gnu/packages/games.scm (lolcat): New package.
> 
> [...]
> 
> > +           (replace 'install
> > +             (lambda* (#:key outputs #:allow-other-keys)
> > +               (let ((dest (map (lambda (path) (string-append path
> > "/bin"))
> > +                                (list (assoc-ref outputs "out")
> > +                                      (assoc-ref outputs
> > "censor")))))
> > +                 (for-each mkdir-p dest)
> > +                 (install-file "lolcat" (car dest))
> > +                 (install-file "censor" (cadr dest))
> > +                 #t))))))
> > +      (outputs (list "out" "censor"))
> 
> Can’t we keep them both in the same output?  Separate outputs are
> normally only used when it helps save space, but I don’t think that’s
> a
> concern here.  :-)
Of course we can.  I initially separated them, because it's really two
very different programs put into one git repo, but of course the
separation serves no real purpose.

> > +      (home-page "https://github.com/jaseg/lolcat")
> > +      (synopsis "Rainbow coloring effect for text console
> > display")
> > +      (description "Lolcat concatenates files and streams like
> > regular cat,
>                        ^                                             
>      ^
> Maybe @command{cat} and @command{lolcat}.
Not sure about @command{lolcat}, since it's at the start of the
sentence, but okay.

> Could you send an updated patch?
> 
> Thanks,
> Ludo’.
Patch is attached.

Regards,
Leo
diff mbox series

Patch

From 42827748e50fe20fdf23ff1137067a7d6c80c87e Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Wed, 4 Dec 2019 02:46:44 +0100
Subject: [PATCH] gnu: Add lolcat

* gnu/packages/games.scm (lolcat): New package.
---
 gnu/packages/games.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ded27c1f63..1f08dd240a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -502,6 +502,44 @@  cows can think too: all you have to do is run @command{cowthink}.  If you're
 tired of cows, a variety of other ASCII-art messengers are available.")
     (license license:gpl3+)))
 
+(define-public lolcat
+  (let ((commit "35dca3d0a381496d7195cd78f5b24aa7b62f2154")
+        (revision "0"))
+    (package
+      (name "lolcat")
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/jaseg/lolcat.git")
+               (commit commit)))
+         (sha256
+          (base32
+           "0jjbkqcc2ikjxd1xgdyv4rb0vsw218181h89f2ywg29ffs3ypd8g"))
+         (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f ;; no check target
+         #:make-flags (list "CC=gcc")
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'bootstrap)
+           (delete 'configure)
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((dest (string-append path "/bin")))
+                 (mkdir-p dest)
+                 (install-file "lolcat" dest)
+                 #t))))))
+      (outputs (list "out" "censor"))
+      (home-page "https://github.com/jaseg/lolcat")
+      (synopsis "Rainbow coloring effect for text console display")
+      (description "@command{lolcat} concatenates files and streams like
+regular @command{cat}, but it also adds terminal escape codes between
+characters and lines resulting in a rainbow effect.")
+      (license license:wtfpl2))))
+
 (define-public freedoom
   (package
     (name "freedoom")
-- 
2.24.0