diff mbox series

[bug#45721] Telegram Desktop (v27)

Message ID a90526b3-6a31-bb2f-af36-609a8cd6ad20@web.de
State Accepted
Headers show
Series [bug#45721] Telegram Desktop (v27) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Jonathan Brielmaier Jan. 31, 2021, 4:50 p.m. UTC
On 31.01.21 15:10, Leo Prikler wrote:
> Hi Jonathan,
> Am Sonntag, den 31.01.2021, 14:57 +0100 schrieb Jonathan Brielmaier:
>> Hi Raghav,
>>
>> thanks for your hard work on Telegram! I always avoided it as I know
>> from openSUSE packaging that it's quite a bunch for work...
>>
>> `libchewing` has FAILs in the test suite when building with my
>> standard
>> 12 cores:
>> test-easy-symbol
>> test-fullshape
>>
>> When building with `--cores=1` the test suite passes, maybe we should
>> set the build on parallel. It doesn't take much longer...
>>
>> ~Jonathan
> If you're willing to write up a patch, I'd be happy to push that for
> you.  It seems libchewing fails on CI as well.  Is that the same issue
> you're experiencing or is it a different one?

On i686 and aarch64 are the same both tests mentioned above failing.

So I guess a `#:parallel-tests? #f` is the best solution here. Attached
is my patch, which I would push later if you have no objections...

Comments

Leo Prikler Jan. 31, 2021, 4:56 p.m. UTC | #1
Am Sonntag, den 31.01.2021, 17:50 +0100 schrieb Jonathan Brielmaier:
> On 31.01.21 15:10, Leo Prikler wrote:
> > Hi Jonathan,
> > Am Sonntag, den 31.01.2021, 14:57 +0100 schrieb Jonathan
> > Brielmaier:
> > > Hi Raghav,
> > > 
> > > thanks for your hard work on Telegram! I always avoided it as I
> > > know
> > > from openSUSE packaging that it's quite a bunch for work...
> > > 
> > > `libchewing` has FAILs in the test suite when building with my
> > > standard
> > > 12 cores:
> > > test-easy-symbol
> > > test-fullshape
> > > 
> > > When building with `--cores=1` the test suite passes, maybe we
> > > should
> > > set the build on parallel. It doesn't take much longer...
> > > 
> > > ~Jonathan
> > If you're willing to write up a patch, I'd be happy to push that
> > for
> > you.  It seems libchewing fails on CI as well.  Is that the same
> > issue
> > you're experiencing or is it a different one?
> 
> On i686 and aarch64 are the same both tests mentioned above failing.
> 
> So I guess a `#:parallel-tests? #f` is the best solution here.
> Attached
> is my patch, which I would push later if you have no objections...
I'd personally pack the comment inside the list, otherwise LGTM.
Jonathan Brielmaier Jan. 31, 2021, 5:01 p.m. UTC | #2
On 31.01.21 17:56, Leo Prikler wrote:
>> On i686 and aarch64 are the same both tests mentioned above failing.
>>
>> So I guess a `#:parallel-tests? #f` is the best solution here.
>> Attached
>> is my patch, which I would push later if you have no objections...
> I'd personally pack the comment inside the list, otherwise LGTM.
>

Hint accepted and pushed as 63c237d0448d92b3f0b0f9e9c337b2078a27a715.
Raghav Gururajan Jan. 31, 2021, 7:14 p.m. UTC | #3
Hi Jonathan!

>>> On i686 and aarch64 are the same both tests mentioned above failing.
>>>
>>> So I guess a `#:parallel-tests? #f` is the best solution here.
>>> Attached
>>> is my patch, which I would push later if you have no objections...
>> I'd personally pack the comment inside the list, otherwise LGTM.
>>
> 
> Hint accepted and pushed as 63c237d0448d92b3f0b0f9e9c337b2078a27a715.

Thanks for fixing it.

Regards,
RG.
diff mbox series

Patch

From 67286626b74daff396c33fe9d8fca6f77f58642b Mon Sep 17 00:00:00 2001
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Date: Sun, 31 Jan 2021 17:47:20 +0100
Subject: [PATCH] gnu: libchewing: Disable parallel tests.

Some tests fail constant when building with multiple threads.

* gnu/packages/language.scm (libchewing)[arguments]: Set
`parallel-tests` to false.
---
 gnu/packages/language.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 67b519aa56..ed6c0e6686 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -287,7 +287,9 @@  Random Cage Fighting Birds, Cool Music etc.")
         (base32 "04d09w6xdd08v6laj9y4qmqsijw5i2jvshcilhh4vg6cfnfgl2my"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+      ;; test-easy-symbol and test-fullshape fail with multiple cores.
+     `(#:parallel-tests? #f
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'disable-failing-tests
            (lambda _
-- 
2.30.0