diff mbox series

[bug#73124,v2,1/3] gnu: wlroots: Remove hwdata patch

Message ID a8d279e5efc6e1600696dc0f087fd94cc454ebee.1725819647.git.rutherther@protonmail.com
State New
Headers show
Series gnu: wlroots: update on mesa-updates | expand

Commit Message

Rutherther Sept. 8, 2024, 6:26 p.m. UTC
* gnu/packages/wm.scm: remove wlroots patch wlroots-hwdata-fallback.patch,
since it's no longer necessary as hwdata package has "share/pkgconfig/hwdata.pc"
* gnu/packages/patches/wlroots-hwdata-fallback.patch: Remove unused patch
* gnu/local.mk: Remove reference of removed gnu/packages/patches/wlroots-hwdata-fallback.patch

Change-Id: I4be3e203b99f1d8e4d837164d55a8c06c8fc71ee
---
 gnu/local.mk                                  |  1 -
 .../patches/wlroots-hwdata-fallback.patch     | 46 -------------------
 gnu/packages/wm.scm                           |  4 +-
 3 files changed, 1 insertion(+), 50 deletions(-)
 delete mode 100644 gnu/packages/patches/wlroots-hwdata-fallback.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index cf42e2b6da..4a2b1c1dbe 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2288,7 +2288,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/webrtc-audio-processing-x86-no-sse.patch	\
   %D%/packages/patches/webrtc-for-telegram-desktop-unbundle-libsrtp.patch \
   %D%/packages/patches/websocketpp-fix-for-cmake-3.15.patch	\
-  %D%/packages/patches/wlroots-hwdata-fallback.patch		\
   %D%/packages/patches/wmctrl-64-fix.patch			\
   %D%/packages/patches/wmfire-dont-inline-draw-fire.patch	\
   %D%/packages/patches/wmfire-update-for-new-gdk-versions.patch	\
diff --git a/gnu/packages/patches/wlroots-hwdata-fallback.patch b/gnu/packages/patches/wlroots-hwdata-fallback.patch
deleted file mode 100644
index 6468c7cbf3..0000000000
--- a/gnu/packages/patches/wlroots-hwdata-fallback.patch
+++ /dev/null
@@ -1,46 +0,0 @@ 
-backend/drm: add hardcoded hwdata path fallback
-
-Add hardcoded fallback "/usr/share/hwdata/pnp.ids" as a
-temporary solution to get things working in Guix until
-hwdata ships with pkg-config file.
-
-diff --git a/backend/drm/meson.build b/backend/drm/meson.build
-index 6fcb2c15..ed95360a 100644
---- a/backend/drm/meson.build
-+++ b/backend/drm/meson.build
-@@ -1,8 +1,7 @@
- hwdata = dependency(
- 	'hwdata',
--	required: 'drm' in backends,
-+	required: false,
- 	native: true,
--	not_found_message: 'Required for the DRM backend.',
- )
- 
- libdisplay_info = dependency(
-@@ -19,15 +18,21 @@ libliftoff = dependency(
- 	required: false,
- )
- 
--if not (hwdata.found() and libdisplay_info.found() and features['session'])
-+if hwdata.found()
-+	hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
-+	pnp_ids = files(hwdata_dir / 'pnp.ids')
-+else
-+	pnp_ids = files('/usr/share/hwdata/pnp.ids')
-+endif
-+
-+if not (libdisplay_info.found() and features['session'])
- 	subdir_done()
- endif
- 
--hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
- pnpids_c = custom_target(
- 	'pnpids.c',
- 	output: 'pnpids.c',
--	input: files(hwdata_dir / 'pnp.ids'),
-+	input: pnp_ids,
- 	feed: true,
- 	capture: true,
- 	command: files('gen_pnpids.sh'),
-
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7d7ac3498f..30ae699550 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1735,9 +1735,7 @@  (define-public wlroots
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0niigjpy8xxrnw3v9b3bsksw2q3yy3qsa2xx0aazwpycw5zrff83"))
-         ;; This patch can be removed once hwdata in Guix supports pkg-config
-         (patches (search-patches "wlroots-hwdata-fallback.patch"))))
+        (base32 "0niigjpy8xxrnw3v9b3bsksw2q3yy3qsa2xx0aazwpycw5zrff83"))))
     (build-system meson-build-system)
     (arguments
      `(#:phases