[bug#76324,4/6] gnu: sync: add seafile-client-qt5
Commit Message
* gnu/packages/sync.scm (seafile-client-qt5): New package.
Change-Id: Iac6e62db24f5a9445d1ee2ebfa0a4713c17abd91
---
gnu/packages/sync.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)
@@ -754,3 +754,20 @@ (define-public seafile-client
(sha256
(base32 "1hivlwbpkj4j42s49z0fj0xp1wyxr67nl6sqy1ydbiij65f48bkp"))))))
+(define-public seafile-client-qt5
+ (package
+ (inherit seafile-client)
+ (name "seafile-client-qt5")
+ (inputs (modify-inputs (package-inputs seafile-client)
+ (replace "qttools" qttools-5)
+ (replace "qtwebengine" qtwebengine-5)
+ (delete "qt5compat")))
+ (arguments
+ (substitute-keyword-arguments (package-arguments seafile-client)
+ ((#:qtbase x)
+ qtbase-5)
+ ((#:configure-flags flags)
+ `(cons "-DBUILD_TESTING=ON"
+ ,flags))
+ ((#:tests? x)
+ #t)))))