diff mbox series

[bug#64542] gnu: Add python-ovh.

Message ID a8877e1ee0c1e0f889cb45c9f2488175a4fabd8f.1688919399.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#64542] gnu: Add python-ovh. | expand

Commit Message

Liliana Marie Prikler July 9, 2023, 1:58 p.m. UTC
* gnu/packages/python-web.scm (python-ovh): New variable.
---
 gnu/packages/python-web.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 8306d3e52902c0d9cffd9a79b379c917c8cf49be

Comments

Liliana Marie Prikler July 16, 2023, 7:25 a.m. UTC | #1
Am Sonntag, dem 09.07.2023 um 15:58 +0200 schrieb Liliana Marie
Prikler:
> * gnu/packages/python-web.scm (python-ovh): New variable.
> ---
Pushed.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d0ac175039..7ac1ef236a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -778,6 +778,34 @@  (define-public python-aws-xray-sdk
 emit information from within their applications to the AWS X-Ray service.")
     (license license:asl2.0)))
 
+(define-public python-ovh
+  (package
+    (name "python-ovh")
+    (version "1.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "ovh" version))
+              (sha256
+               (base32
+                "0ygniv12lixh9rvnjcd01gzbzk2b5xwcg2a59b7964a77dd9p3qh"))))
+    (build-system pyproject-build-system)
+    (arguments (list #:tests? #f))      ; XXX: tests require networking
+    (propagated-inputs (list python-requests))
+    (native-inputs (list python-black
+                         python-coverage
+                         python-flake8
+                         python-isort
+                         python-pytest
+                         python-pytest-cov
+                         python-setuptools
+                         python-sphinx
+                         python-wheel))
+    (home-page "https://api.ovh.com")
+    (synopsis "Interact with OVHcloud APIs")
+    (description "This package provides the official module to perform HTTP requests
+to the OVHcloud APIs.")
+    (license license:bsd-3)))
+
 (define-public python-cbor2
   (package
     (name "python-cbor2")