diff mbox series

[bug#36824] gnu: Add oshu.

Message ID a7e9ac17-c288-7882-ab84-b6c4c1d435a6@cs.ru.nl
State Accepted
Headers show
Series [bug#36824] gnu: Add oshu. | expand

Commit Message

Dan Frumin July 28, 2019, 11:42 a.m. UTC
Sorry, I forgot to do the linting.
Here is an updated version with two spaces.

Best,
Dan

On 27-07-19 20:18, Dan Frumin wrote:
> ---
>   gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
>   1 file changed, 34 insertions(+)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index a17ac9728c..3bb17c5735 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -6374,6 +6374,40 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
>       (home-page "https://www.stepmania.com")
>       (license license:expat)))
>   
> +(define-public oshu
> +  (package
> +    (name "oshu")
> +    (version "2.0.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/fmang/oshu.git")
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "01w1x46hh36idjl94xd18dwppp0y30qxmb498gp7hnjzy205q6rw"))))
> +    (build-system cmake-build-system)
> +    (native-inputs `(("pkg-config" ,pkg-config)))
> +    (inputs `(("sdl2" ,sdl2)
> +              ("sdl2-image" ,sdl2-image)
> +              ("ffmpeg" ,ffmpeg)
> +              ("cairo" ,cairo)
> +              ("pango" ,pango)))
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         ;; `make test' doesn't actually build the test executable
> +         (add-before 'check 'zerotokei
> +           (lambda _ (invoke "make" "zerotokei"))))))
> +    (home-page "https://github.com/fmang/oshu/")
> +    (synopsis "Clone of the Osu! rhythm game")
> +    (description "Oshu! is a free clone of the Osu! rhythm game, designed to
> +be run on GNU/Linux without requiring a powerful videocard. Oshu! is capable
> +of playing the original Osu! beatmaps (not included in this package). ")
> +    (license license:gpl3)))
> +
>   (define-public btanks
>     (package
>       (name "btanks")
>

Comments

guix--- via Guix-patches via July 28, 2019, 4:07 p.m. UTC | #1
Dan,

Thanks!  I'm deprived of Guix for the moment, so I can't review 
the package itself.  Looks good on first glance, though.

Dan Frumin 写道:
>    (synopsis "Clone of the Osu! rhythm game")
>    (description "Oshu! is a free clone of the Osu! rhythm game, 
>    designed to

I'd rather see a 'first-class' description of what this game is 
and does and drop the 'is a clone of' part entirely: 'is capable 
of playing the original Osu! beatmaps' already says it all without 
implying it's some kind of knock-off ;-)

If you don't have time fo' that I understand, but you're 
presumably familiar with both games & in the best position to 
write something accurate.

> be run on GNU/Linux without requiring a powerful videocard. 
> Oshu! is capable

s/videocard/video card/, or graphics card.  Is it really tied to 
the kernel?  (Not entirely implausible considering the real-time 
audio nature.  Interesting design, by the way.)

> of playing the original Osu! beatmaps (not included in this 
> package). ")

Could we package these separately?  How are they licenced?

>    (license license:gpl3)))

Ugh, no licence headers?  I guess that does make it GPL 3-only, 
but I'm no expert.

Kind regards,

T G-R
diff mbox series

Patch

From ae5604a22c196386f514b59fb81616558a2e60f1 Mon Sep 17 00:00:00 2001
From: Dan Frumin <dfrumin@cs.ru.nl>
Date: Sat, 27 Jul 2019 20:18:22 +0200
Subject: [PATCH] gnu: Add oshu.

---
 gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a17ac9728c..b65c842735 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6374,6 +6374,40 @@  to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
     (home-page "https://www.stepmania.com")
     (license license:expat)))
 
+(define-public oshu
+  (package
+    (name "oshu")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fmang/oshu.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "01w1x46hh36idjl94xd18dwppp0y30qxmb498gp7hnjzy205q6rw"))))
+    (build-system cmake-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("sdl2" ,sdl2)
+              ("sdl2-image" ,sdl2-image)
+              ("ffmpeg" ,ffmpeg)
+              ("cairo" ,cairo)
+              ("pango" ,pango)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; `make test' doesn't actually build the test executable
+         (add-before 'check 'zerotokei
+           (lambda _ (invoke "make" "zerotokei"))))))
+    (home-page "https://github.com/fmang/oshu/")
+    (synopsis "Clone of the Osu! rhythm game")
+    (description "Oshu! is a free clone of the Osu! rhythm game, designed to
+be run on GNU/Linux without requiring a powerful videocard.  Oshu! is capable
+of playing the original Osu! beatmaps (not included in this package). ")
+    (license license:gpl3)))
+
 (define-public btanks
   (package
     (name "btanks")
-- 
2.17.1