diff mbox series

[bug#67058,gnome-team,1/4] gnu: gtk: Update to 4.12.3.

Message ID a7e831a556accc2f937bf8d7f54977037b128f81.1699663262.git.liliana.prikler@gmail.com
State New
Headers show
Series Upate libadwaita to 1.4.0 | expand

Commit Message

Liliana Marie Prikler Nov. 11, 2023, 12:19 a.m. UTC
* gnu/packages/gtk.scm (gtk): Update to 4.12.3.
[source]: Remove snippet.
[arguments]<#:configure-flags>: Add “--no-suite=headless”.
<#:phases>: Also patch text-color tests in gsk/nodeparser.

Change-Id: Iedabfd12ae4f60f02ea21f427b85aeb6b17d03d6
---
 gnu/packages/gtk.scm | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)

Comments

Maxim Cournoyer Dec. 3, 2023, 5:24 p.m. UTC | #1
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/gtk.scm (gtk): Update to 4.12.3.
> [source]: Remove snippet.
> [arguments]<#:configure-flags>: Add “--no-suite=headless”.
> <#:phases>: Also patch text-color tests in gsk/nodeparser.
>
> Change-Id: Iedabfd12ae4f60f02ea21f427b85aeb6b17d03d6
> ---
>  gnu/packages/gtk.scm | 11 +++++++----
>  1 file changed, 7 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 21a12689b7..6a0f5e0773 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -1119,7 +1119,7 @@ (define-public gtk+
>  (define-public gtk
>    (package
>      (name "gtk")
> -    (version "4.10.3")
> +    (version "4.12.3")
>      (source
>       (origin
>         (method url-fetch)
> @@ -1127,11 +1127,10 @@ (define-public gtk
>                             (version-major+minor version)  "/"
>                             name "-" version ".tar.xz"))
>         (sha256
> -        (base32 "1aff06l9v40j16s4s0qvdbj8cs54qxnh41d7w2v7wdwyswd48ia5"))
> +        (base32 "128ahzsj016vz8brd8kplhfkxg2q7wy7kndibx2qfr68yrif530l"))
>         (patches
>          (search-patches "gtk4-respect-GUIX_GTK4_PATH.patch"))
> -       (modules '((guix build utils)))
> -       (snippet #~(begin (delete-file-recursively "subprojects/gi-docgen")))))
> +       (modules '((guix build utils)))))

If we don't need the snippet, we don't need the 'modules' field either.

>      (build-system meson-build-system)
>      (outputs '("out" "bin" "doc"))
>      (arguments
> @@ -1157,6 +1156,7 @@ (define-public gtk
>                              "--suite=gtk"
>                              "--no-suite=failing"
>                              "--no-suite=flaky"
> +                            "--no-suite=headless" ; requires mutter…

Instead of the '...', maybe explicit that 'XXX: Requires mutter, which
transitively requires this package.' on a standalone comment.

>                              "--no-suite=gsk-compare-broadway")
>        #:phases
>        #~(modify-phases %standard-phases
> @@ -1179,6 +1179,9 @@ (define-public gtk
>                (substitute* "meson.build"
>                  (("gtk_update_icon_cache: true")
>                   "gtk_update_icon_cache: false"))
> +              (substitute* (find-files "testsuite/gsk/nodeparser/"
> +                                       "^text-color.*\\.node$")
> +                (("Noto Sans") "DejaVu Sans"))
>                ;; Disable failing tests.
>                (substitute* (find-files "testsuite" "meson.build")
>                  (("[ \t]*'empty-text.node',") "")

Otherwise,

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 21a12689b7..6a0f5e0773 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1119,7 +1119,7 @@  (define-public gtk+
 (define-public gtk
   (package
     (name "gtk")
-    (version "4.10.3")
+    (version "4.12.3")
     (source
      (origin
        (method url-fetch)
@@ -1127,11 +1127,10 @@  (define-public gtk
                            (version-major+minor version)  "/"
                            name "-" version ".tar.xz"))
        (sha256
-        (base32 "1aff06l9v40j16s4s0qvdbj8cs54qxnh41d7w2v7wdwyswd48ia5"))
+        (base32 "128ahzsj016vz8brd8kplhfkxg2q7wy7kndibx2qfr68yrif530l"))
        (patches
         (search-patches "gtk4-respect-GUIX_GTK4_PATH.patch"))
-       (modules '((guix build utils)))
-       (snippet #~(begin (delete-file-recursively "subprojects/gi-docgen")))))
+       (modules '((guix build utils)))))
     (build-system meson-build-system)
     (outputs '("out" "bin" "doc"))
     (arguments
@@ -1157,6 +1156,7 @@  (define-public gtk
                             "--suite=gtk"
                             "--no-suite=failing"
                             "--no-suite=flaky"
+                            "--no-suite=headless" ; requires mutter…
                             "--no-suite=gsk-compare-broadway")
       #:phases
       #~(modify-phases %standard-phases
@@ -1179,6 +1179,9 @@  (define-public gtk
               (substitute* "meson.build"
                 (("gtk_update_icon_cache: true")
                  "gtk_update_icon_cache: false"))
+              (substitute* (find-files "testsuite/gsk/nodeparser/"
+                                       "^text-color.*\\.node$")
+                (("Noto Sans") "DejaVu Sans"))
               ;; Disable failing tests.
               (substitute* (find-files "testsuite" "meson.build")
                 (("[ \t]*'empty-text.node',") "")