diff mbox series

[bug#58500] gnu: add rofi-wayland

Message ID a78a2a09e0cda39aadce9eaf131fb9d1aca013fd.1665674070.git.florhizome@posteo.net
State New
Headers show
Series [bug#58500] gnu: add rofi-wayland | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

florhizome Oct. 13, 2022, 3:22 p.m. UTC
From: florhizome <florhizome@posteo.net>

This adds a wayland compatible fork of rofi. 


---
 gnu/packages/xdisorg.scm | 46 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)


base-commit: 86ec52f66735b122b9035eba56516fd16f3be958
prerequisite-patch-id: 253e1cc8278ab9981294f4e483c7b29a466672d9
prerequisite-patch-id: fb797b9fdd73d1c18cba5dbd5804396d333f13df

Comments

Christopher Baines Dec. 6, 2022, 10:17 a.m. UTC | #1
florhizome@posteo.net writes:

> From: florhizome <florhizome@posteo.net>
>
> This adds a wayland compatible fork of rofi. 
>
>
> ---
>  gnu/packages/xdisorg.scm | 46 ++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 46 insertions(+)

rofi-wayland was added in #59241, I'm sorry this patch was missed.

I'm going to close this issue, but please open another if there are any
changes that are still worth making.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 2533744633..2dbee6f7b6 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1860,6 +1860,52 @@  (define-public rofi
 by name.")
     (license license:expat)))
 
+(define-public rofi-wayland
+  (package
+    (inherit rofi)
+    (name "rofi-wayland")
+    (version "1.7.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/lbonn/rofi")
+         (commit
+           (string-append version "+wayland1"))
+          (recursive? #t)))
+       (sha256
+          (base32 "0d2h1ys05sixwf508b3cqaailjibh56009cnjz809akgndbqplkm"))
+         (file-name (git-file-name name version))))
+    (build-system meson-build-system)
+    (arguments
+     (list #:tests? #f ;;last test fails
+           #:parallel-tests? #f             ; fails in some circumstances
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'configure 'adjust-tests
+                 (lambda _
+                   (substitute* '("test/helper-expand.c")
+                     (("~root") "/root")
+                     (("~") "")
+                     (("g_get_home_dir \\(\\)") "\"/\"")))))))
+    (inputs (modify-inputs
+             (package-inputs rofi)
+             (append wayland-protocols gdk-pixbuf wayland)))
+    (synopsis "Rofi fork that's wayland-ready")
+    (description "This is a fork of Rofi with added support for Wayland via the
+ layer shell protocol.
+Differences with rofi (in wayland mode):
+@itemize
+@item native window selection mode when running under Wayland.
+@item -normal-window flag in Wayland mode.
+@item selecting which monitor to run rofi on in Wayland mode,
+ rofi only shows up on the currently focused monitor
+@item some window locations parameters work partially, x-offset
+ and y-offset are only working from screen edges
+@item some X11-specific options like -dpi or fake transparency
+@end itemize")))
+
 (define-public rofi-calc
   (package
     (name "rofi-calc")