diff mbox series

[bug#67869] gnu: Add font-google-roboto-mono.

Message ID a76a63d9-9934-a7e9-4626-6139120ea5cd@vodafonemail.de
State New
Headers show
Series [bug#67869] gnu: Add font-google-roboto-mono. | expand

Commit Message

Stefan Dec. 17, 2023, 4:41 p.m. UTC
* gnu/packages/fonts.scm (font-google-roboto-mono): New variable.

Change-Id: I3b18c1a5a8416f2e4429a05b5ef3f2d434ffe871
---
  gnu/packages/fonts.scm | 37 +++++++++++++++++++++++++++++++++++++
  1 file changed, 37 insertions(+)


base-commit: 6ab242609daec00e8bd54f7bff54557c92695724
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 813367be8a..a5687ee7f6 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -59,6 +59,7 @@ 
  ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
  ;;; Copyright © 2023 chris <chris@bumblehead.com>
  ;;; Copyright © 2023 Luis Felipe López Acevedo <sirgazil@zoho.com>
+;;; Copyright © 2023 Stefan <stefan-guix@vodafonemail.de>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -1134,6 +1135,42 @@  (define-public font-google-roboto
  visual language \"Material Design\".")
      (license license:asl2.0)))
  
+(define-public font-google-roboto-mono
+  (package
+    (name "font-google-roboto-mono")
+    ;; The version is taken from the comment of git commit
+    ;; 4df0b673c9b316ad5e8de8fa70b0768ab66c87d6, which is the last
+    ;; modification of the RobotoMono*.ttf files in commit
+    ;; b81989291cb1fc953ac039ed16b3e2ae4685ab33.
+    (version "3.000")
+    (source
+      (origin
+        ;; The subversion bridge of GitHub allows to only fetch a sub-directory.
+        (method svn-fetch)
+        (uri
+          (svn-reference
+            (url "https://github.com/google/fonts/trunk/apache/robotomono")
+            ;; This SVN revision matches the git commit
+            ;; b81989291cb1fc953ac039ed16b3e2ae4685ab33.
+            (revision 103762)))
+       (sha256
+         (base32 "0zlprs2cnvld62khb741kdqgwpjsp1cw5wmm8ghzgq9hbfk3fhad"))))
+    (build-system font-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'install-license-files 'change-directory-to-license
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (chdir "trunk/apache/robotomono"))))))
+    (home-page "https://github.com/google/fonts/tree/main/apache/robotomono")
+    (synopsis "The Roboto Mono family of fonts")
+    ;; The description is taken from the file DESCRIPTION.en_us.html.
+    (description
+     "Roboto Mono is a monospaced addition to the Roboto type family.  Like the
+other members of the Roboto family, the fonts are optimized for readability on
+screens across a wide variety of devices and reading environments.")
+    (license license:asl2.0)))
+
  (define-public font-borg-sans-mono
    (package
      (name "font-borg-sans-mono")