diff mbox series

[bug#74356,05/10] gnu: dune-istl: Update to 2.10.0.

Message ID a7032cefb9ff78905205d582ace918481a71cf0d.1731615040.git.felgru@posteo.net
State New
Headers show
Series Update dune-* to 2.10.0. | expand

Commit Message

Felix Gruber Nov. 14, 2024, 8:21 p.m. UTC
* gnu/packages/maths.scm (dune-istl): Update to 2.10.0.
  [source]: Remove patch that has been applied upstream.
* gnu/packages/patches/dune-istl-fix-solver-playground.patch: Remove
  file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Change-Id: Ifbbb6f2dea815159a1743ae6e622c154cf1cc9b0
---
 gnu/local.mk                                  |  1 -
 gnu/packages/maths.scm                        |  5 +-
 .../dune-istl-fix-solver-playground.patch     | 61 -------------------
 3 files changed, 2 insertions(+), 65 deletions(-)
 delete mode 100644 gnu/packages/patches/dune-istl-fix-solver-playground.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index dcc1aa201a..5adebbee41 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1167,7 +1167,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/dtc-meson-cell-overflow.patch		\
   %D%/packages/patches/duc-fix-test-sh.patch                    \
   %D%/packages/patches/dune-common-skip-failing-tests.patch	\
-  %D%/packages/patches/dune-istl-fix-solver-playground.patch	\
   %D%/packages/patches/durden-shadow-arcan.patch		\
   %D%/packages/patches/dvd+rw-tools-add-include.patch 		\
   %D%/packages/patches/dwarves-threading-reproducibility.patch	\
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index bb40f046dd..799e9115a1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8539,7 +8539,7 @@  (define-public dune-grid
 (define-public dune-istl
   (package
     (name "dune-istl")
-    (version "2.9.0")
+    (version "2.10.0")
     (source
      (origin
        (method url-fetch)
@@ -8547,8 +8547,7 @@  (define-public dune-istl
                            version "/dune-istl-" version ".tar.gz"))
        (sha256
         (base32
-         "0smghqr400xl84j0laabgwaj2p5jlj3n3s85bm7qp9m2vjz6rav6"))
-       (patches (search-patches "dune-istl-fix-solver-playground.patch"))))
+         "0rk95rkj87gpb3gn40jl532rybs2lxkhn7g6b30m9kbzz7yfjfbc"))))
     (build-system cmake-build-system)
     (arguments
      `(#:phases
diff --git a/gnu/packages/patches/dune-istl-fix-solver-playground.patch b/gnu/packages/patches/dune-istl-fix-solver-playground.patch
deleted file mode 100644
index b3df4b6ffa..0000000000
--- a/gnu/packages/patches/dune-istl-fix-solver-playground.patch
+++ /dev/null
@@ -1,61 +0,0 @@ 
-From fe929f17e98b577171f58ca520b5145be41730ea Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Christoph=20Gr=C3=BCninger?= <gruenich@dune-project.org>
-Date: Thu, 16 Mar 2023 19:48:40 +0100
-Subject: [PATCH] Adjust sequential and both parallel cases in
- istl-solver-playground
-
-Do same thing, independent of paralellel, distributed, or
-sequential.
-This fixes the test in the sequential case.
----
- src/istl-solver-playground.hh | 22 ++++++++++++++++------
- 1 file changed, 16 insertions(+), 6 deletions(-)
-
-diff --git a/src/istl-solver-playground.hh b/src/istl-solver-playground.hh
-index 0ff3abd5..11693cf5 100644
---- a/src/istl-solver-playground.hh
-+++ b/src/istl-solver-playground.hh
-@@ -66,7 +66,11 @@ std::shared_ptr<OOCOMM> loadSystem(std::shared_ptr<Mat>& m,
-   std::shared_ptr<OOCOMM> oocomm;
-   if(distributed){
-     oocomm = std::make_shared<OOCOMM>(MPI_COMM_WORLD);
--    loadMatrixMarket(*m, matrixfilename, *oocomm);
-+    if(matrixfilename != "laplacian"){
-+      loadMatrixMarket(*m, matrixfilename, *oocomm);
-+    }else{
-+      setupLaplacian(*m, config.get("N", 20));
-+    }
-     if(config.get("random_rhs", false)){
-       rhs->resize(m->N());
-       srand(42);
-@@ -98,16 +102,22 @@ template<class Mat, class Vec>
- void loadSystem(std::shared_ptr<Mat>& m,
-                 std::shared_ptr<Vec>& rhs,
-                 const Dune::ParameterTree& config){
--  std::string matrixfilename = config.get<std::string>("matrix");
-+  // generate Laplacian or load matrix
-+  std::string matrixfilename = config.get<std::string>("matrix", "laplacian");
-+  if(matrixfilename == "laplacian"){
-+    setupLaplacian(*m, config.get("N", 20));
-+  }else{
-+    loadMatrixMarket(*m, matrixfilename);
-+  }
-+  // use random values or load right-hand side
-   std::string rhsfilename;
--  if(!config.get("random_rhs", false))
--    rhsfilename = config.get<std::string>("rhs");
--  loadMatrixMarket(*m, matrixfilename);
-   if(config.get("random_rhs", false)){
-     rhs->resize(m->N());
-     fillRandom(*rhs);
--  }else
-+  }else{
-+    rhsfilename = config.get<std::string>("rhs");
-     loadMatrixMarket(*rhs, rhsfilename);
-+  }
- }
- #endif
- 
--- 
-2.39.2
-