diff mbox series

[bug#63766,4/4] gnu: glibc-2.33: Fix building for riscv64-linux.

Message ID a6f86073098eae5dcd6a4bac7bb6eb1c88adbb04.1685266344.git.efraim@flashner.co.il
State New
Headers show
Series Image for HiFive Unmatched | expand

Commit Message

Efraim Flashner May 28, 2023, 9:44 a.m. UTC
* gnu/packages/base.scm (glibc-2.33)[source]: Add patch.
* gnu/packages/patches/glibc-2.33-rawmemchr-miscompilation.patch: New
file.
* gnu/local.mk (dist_patch_DATA): Register it.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/base.scm                         | 16 ++++--
 .../glibc-2.33-rawmemchr-miscompilation.patch | 57 +++++++++++++++++++
 3 files changed, 68 insertions(+), 6 deletions(-)
 create mode 100644 gnu/packages/patches/glibc-2.33-rawmemchr-miscompilation.patch

Comments

Ludovic Courtès June 9, 2023, 8:49 p.m. UTC | #1
Efraim Flashner <efraim@flashner.co.il> skribis:

> * gnu/packages/base.scm (glibc-2.33)[source]: Add patch.
> * gnu/packages/patches/glibc-2.33-rawmemchr-miscompilation.patch: New
> file.
> * gnu/local.mk (dist_patch_DATA): Register it.

[...]

> +               (cons* (search-patch "glibc-2.33-rawmemchr-miscompilation.patch")
> +                 ;; Remove a patch that's become irrelevant and that does not
> +                 ;; apply to this version.
> +                 (remove (lambda (patch)
> +                           (string=? (basename patch)
> +                                     "glibc-hurd-clock_gettime_monotonic.patch"))
> +                         (origin-patches (package-source glibc)))))))

The indentation is off.  You can use ‘cons’ rather than ‘cons*’.

> +++ b/gnu/packages/patches/glibc-2.33-rawmemchr-miscompilation.patch
> @@ -0,0 +1,57 @@
> +This patch is from upstream glibc after 2.33 and is needed in Guix to
> +fix glibc-2.33 compilation for riscv64-linux.

Maybe rename it ‘glibc-2.33-riscv-compilation.patch’ to make the goal
clearer?

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 50d65a3dba..e8770a3f2a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1235,6 +1235,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/glib-appinfo-watch.patch			\
   %D%/packages/patches/glib-networking-gnutls-binding.patch	\
   %D%/packages/patches/glib-skip-failing-test.patch		\
+  %D%/packages/patches/glibc-2.33-rawmemchr-miscompilation.patch	\
   %D%/packages/patches/glibc-CVE-2019-7309.patch		\
   %D%/packages/patches/glibc-CVE-2019-9169.patch		\
   %D%/packages/patches/glibc-CVE-2019-19126.patch		\
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d2f276c447..dbf1b0edcb 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1066,12 +1066,13 @@  (define-public glibc-2.33
                (base32
                 "1zvp0qdfbdyqrzydz18d9zg3n5ygy8ps7cmny1bvsp8h1q05c99f"))
               (patches
-               ;; Remove a patch that's become irrelevant and that does not
-               ;; apply to this version.
-               (remove (lambda (patch)
-                         (string=? (basename patch)
-                                   "glibc-hurd-clock_gettime_monotonic.patch"))
-                       (origin-patches (package-source glibc))))))
+               (cons* (search-patch "glibc-2.33-rawmemchr-miscompilation.patch")
+                 ;; Remove a patch that's become irrelevant and that does not
+                 ;; apply to this version.
+                 (remove (lambda (patch)
+                           (string=? (basename patch)
+                                     "glibc-hurd-clock_gettime_monotonic.patch"))
+                         (origin-patches (package-source glibc)))))))
     (arguments
      (substitute-keyword-arguments (package-arguments glibc)
        ((#:configure-flags flags ''())
@@ -1379,6 +1380,9 @@  (define-public glibc-utf8-locales
    (make-glibc-utf8-locales glibc)))
 
 ;; Packages provided to ease use of binaries linked against the previous libc.
+(define-public glibc-locales-2.33
+  (package (inherit (make-glibc-locales glibc-2.33))
+           (name "glibc-locales-2.33")))
 (define-public glibc-locales-2.32
   (package (inherit (make-glibc-locales glibc-2.32))
            (name "glibc-locales-2.32")))
diff --git a/gnu/packages/patches/glibc-2.33-rawmemchr-miscompilation.patch b/gnu/packages/patches/glibc-2.33-rawmemchr-miscompilation.patch
new file mode 100644
index 0000000000..bcf297be94
--- /dev/null
+++ b/gnu/packages/patches/glibc-2.33-rawmemchr-miscompilation.patch
@@ -0,0 +1,57 @@ 
+This patch is from upstream glibc after 2.33 and is needed in Guix to
+fix glibc-2.33 compilation for riscv64-linux.
+
+From 044e603b698093cf48f6e6229e0b66acf05227e4 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Fri, 19 Feb 2021 13:29:00 +0100
+Subject: [PATCH] string: Work around GCC PR 98512 in rawmemchr
+
+---
+ string/rawmemchr.c | 26 +++++++++++++++-----------
+ 1 file changed, 15 insertions(+), 11 deletions(-)
+
+diff --git a/string/rawmemchr.c b/string/rawmemchr.c
+index 59bbeeaa42..b8523118e5 100644
+--- a/string/rawmemchr.c
++++ b/string/rawmemchr.c
+@@ -22,24 +22,28 @@
+ # define RAWMEMCHR __rawmemchr
+ #endif
+ 
++/* The pragmata should be nested inside RAWMEMCHR below, but that
++   triggers GCC PR 98512.  */
++DIAG_PUSH_NEEDS_COMMENT;
++#if __GNUC_PREREQ (7, 0)
++/* GCC 8 warns about the size passed to memchr being larger than
++   PTRDIFF_MAX; the use of SIZE_MAX is deliberate here.  */
++DIAG_IGNORE_NEEDS_COMMENT (8, "-Wstringop-overflow=");
++#endif
++#if __GNUC_PREREQ (11, 0)
++/* Likewise GCC 11, with a different warning option.  */
++DIAG_IGNORE_NEEDS_COMMENT (11, "-Wstringop-overread");
++#endif
++
+ /* Find the first occurrence of C in S.  */
+ void *
+ RAWMEMCHR (const void *s, int c)
+ {
+-  DIAG_PUSH_NEEDS_COMMENT;
+-#if __GNUC_PREREQ (7, 0)
+-  /* GCC 8 warns about the size passed to memchr being larger than
+-     PTRDIFF_MAX; the use of SIZE_MAX is deliberate here.  */
+-  DIAG_IGNORE_NEEDS_COMMENT (8, "-Wstringop-overflow=");
+-#endif
+-#if __GNUC_PREREQ (11, 0)
+-  /* Likewise GCC 11, with a different warning option.  */
+-  DIAG_IGNORE_NEEDS_COMMENT (11, "-Wstringop-overread");
+-#endif
+   if (c != '\0')
+     return memchr (s, c, (size_t)-1);
+-  DIAG_POP_NEEDS_COMMENT;
+   return (char *)s + strlen (s);
+ }
+ libc_hidden_def (__rawmemchr)
+ weak_alias (__rawmemchr, rawmemchr)
++
++DIAG_POP_NEEDS_COMMENT;
+--