From 717f18057715559f4c847b3a7171a7e5095b7418 Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Fri, 24 Apr 2020 01:23:25 +0530
Subject: [PATCH 1/9] gnu: Add r-tea.
* gnu/packages/cran.scm (r-tea): New variable.
---
gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
@@ -21162,3 +21162,32 @@ evaluated interactively.")
Bayes factors, posterior model probabilities, and normalizing constants in
general, via different versions of bridge sampling.")
(license license:gpl2+)))
+
+(define-public r-tea
+ (package
+ (name "r-tea")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tea" version))
+ (sha256
+ (base32
+ "0ql7lrxk0ihm49kqsvz79ig8i54rwiy9nxav4v9hy72j9kj5bgjn"))))
+ (properties
+ `((upstream-name . "tea")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrix" ,r-matrix)))
+ (home-page "https://cran.r-project.org/web/packages/tea")
+ (synopsis "Threshold estimation approaches")
+ (description
+ "This package provide different approaches for selecting the threshold
+in generalized Pareto distributions. Most of them are based on minimizing the
+AMSE-criterion or atleast by reducing the bias of the assumed GPD-model.
+Others are heuristically motivated by searching for stable sample paths, i.e.
+a nearly constant region of the tail index estimator with respect to k, which
+is the number of data in the tail. The third class is motivated by graphical
+inspection. In addition, a sequential testing procedure for GPD-GoF-tests
+is also implemented here.")
+ (license license:gpl3)))
--
2.25.1