diff mbox series

[bug#40779,Version,2] : bug#40779: Acknowledgement (Submission of CRAN Package Descriptions r-dcv r-stam r-grouped r-sgloptim r-awsmethods r-aws r-tea r-rcdd r-rxnat)

Message ID a6ae6747-28d6-5e44-9f1c-b38066c978ba@riseup.net
State Accepted
Headers show
Series [bug#40779,Version,2] : bug#40779: Acknowledgement (Submission of CRAN Package Descriptions r-dcv r-stam r-grouped r-sgloptim r-awsmethods r-aws r-tea r-rcdd r-rxnat) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Naga Malleswari April 23, 2020, 8:45 p.m. UTC
Hi

On 23/04/20 8:41 pm, Ricardo Wurmus wrote:
> Hi NagaMalli,
>
> thank you for your patches!
>
> Please run “./pre-inst-env guix lint” on each of the packages. 
Yes i actually done lint adding all packages which i realized i have to
do it individually. This took me so long to finish the edits.
>  Please
> pay special attention to the description and synopsis fields.  The
> descriptions often contain sentence fragments – we prefer to have
> complete sentences.  Make sure that there are two spaces after end of
> sentence periods — not zero spaces and not just one space either.
I made the changes as per the suggestions.
> For the synopses please only capitalize proper names (like “Bayes”) and
> the first word.  CRAN packages use capitalization for all words, so we
> need to change that.
>
> Please also run etc/indent-code.el to fix the indentation.  The importer
> doesn’t do the right thing because it doesn’t know about our
> conventions.
I have done and it worked for individual packages
> Could you please send updated patches as a reply to this email thread?
>
> Thank you!

And lastly i built everything and sending the patches. Please review.


> --
> Ricardo

Comments

Ricardo Wurmus April 24, 2020, 2 p.m. UTC | #1
Hi,

thank you for the updated patches.

I applied all of them with a number of changes:

* the indentation of a number of patches was incorrect and had to be
  adjusted
* there were a few typos and spacing issues (e.g. missing space after
  comma) in descriptions
* I changed the home page of one package from the author’s home page to
  the package page on CRAN
* a synopsis missed an important word
* I used HTTPS were possible

Thanks again!

--
Ricardo
diff mbox series

Patch

From 717f18057715559f4c847b3a7171a7e5095b7418 Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Fri, 24 Apr 2020 01:23:25 +0530
Subject: [PATCH 1/9] gnu: Add r-tea.

* gnu/packages/cran.scm (r-tea): New variable.
---
 gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70cb7cc700..2dba2b0a93 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21162,3 +21162,32 @@  evaluated interactively.")
 Bayes factors, posterior model probabilities, and normalizing constants in
 general, via different versions of bridge sampling.")
     (license license:gpl2+)))
+
+(define-public r-tea
+  (package
+    (name "r-tea")
+    (version "1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "tea" version))
+       (sha256
+        (base32
+         "0ql7lrxk0ihm49kqsvz79ig8i54rwiy9nxav4v9hy72j9kj5bgjn"))))
+    (properties
+     `((upstream-name . "tea")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-matrix" ,r-matrix)))
+    (home-page "https://cran.r-project.org/web/packages/tea")
+    (synopsis "Threshold estimation approaches")
+    (description
+     "This package provide different approaches for selecting the threshold
+in generalized Pareto distributions.  Most of them are based on minimizing the
+AMSE-criterion or atleast by reducing the bias of the assumed GPD-model.
+Others are heuristically motivated by searching for stable sample paths, i.e.
+a nearly constant region of the tail index estimator with respect to k, which
+is the number of data in the tail.  The third class is motivated by graphical
+inspection.  In addition, a sequential testing procedure for GPD-GoF-tests
+is also implemented here.")
+    (license license:gpl3)))
-- 
2.25.1