diff mbox series

[bug#67963,4/4] gnu: Add perl-safe-hole.

Message ID a65e9115e75a12f120cc44ee32032fb4baef5e74.1703218207.git.felix.lechner@lease-up.com
State New
Headers show
Series Add Perl modules for debbugs.gnu.org | expand

Commit Message

Felix Lechner Dec. 22, 2023, 4:18 a.m. UTC
* gnu/packages/perl.scm (perl-safe-hole): New variable.

Change-Id: Ifc635a7a7dfecc698b00a822c84aaf858b8abd52
---
 gnu/packages/perl.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d7e37552db..1dff82534c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9363,6 +9363,27 @@  (define-public perl-role-tiny-2
        (sha256
         (base32 "11qn516352yhi794www3ykwa9xv2gxpfnhn9jcn10x0ahl95gflj"))))))
 
+(define-public perl-safe-hole
+  (package
+    (name "perl-safe-hole")
+    (version "0.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/T/TO/TODDR/Safe-Hole-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "01gc2lfli282dj6a2pkpxb0vmpyavs323cbdw15gxi06pn5nxxgl"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build))
+    (home-page "https://metacpan.org/release/Safe-Hole")
+    (synopsis "Make a hole to the original main compartment in the Safe compartment")
+    (description "From the Safe compartment, one can call outside defined subroutines or
+methods through the object that is copied into the Safe compartment, but they too
+run in the Safe compartment.  Through Safe::Hole, we can execute outside defined
+subroutines in the original main compartment from the Safe compartment.")
+    (license license:perl-license)))
+
 (define-public perl-safe-isa
   (package
     (name "perl-safe-isa")