diff mbox series

[bug#67941] gnu: icecat-minimal: Fix dependency to libcanberra.

Message ID a63e3805f97bfe13c9d62775c6979e771ce0db87.1703101859.git.clement@lassieur.org
State New
Headers show
Series [bug#67941] gnu: icecat-minimal: Fix dependency to libcanberra. | expand

Commit Message

Clément Lassieur Dec. 20, 2023, 7:50 p.m. UTC
* gnu/packages/gnuzilla.scm (icecat-minimal)[arguments]: Add
'libcanberra/lib/gtk-3.0/modules' to LD_LIBRARY_PATH in the 'wrap-program'
phase.

Change-Id: I508dbf0a8133634c329c4c1ff20088752311ff91
---
 gnu/packages/gnuzilla.scm | 28 ++++++++++++++++------------
 1 file changed, 16 insertions(+), 12 deletions(-)


base-commit: bb3ab24a296ffa5273b2e82a02ed057e90c095f3
prerequisite-patch-id: 51e2c2aaf5262d0d9001b0b5c37836060291f55d
prerequisite-patch-id: ea15ff59ebfaff0fce3c9a1d42a3c345f8618aab
prerequisite-patch-id: 459d954ba63d5c0c15f8b519aa5aef331f218cc6
prerequisite-patch-id: cc5c8cd318ced4bb10d30f2e00b41b1be1309226
prerequisite-patch-id: 32045c6f50d674987ad6be5b15b8f4f010123c37
prerequisite-patch-id: c0b3ddac8628924c3db8daf2d9694e0de9fb7e5e
prerequisite-patch-id: 9c1d2bed61258b47220ac60fbb889348877ebfb7
prerequisite-patch-id: 4d717985fc3ba49304969527f92f2d854b677fae

Comments

Jonathan Brielmaier Dec. 21, 2023, 11:23 a.m. UTC | #1
Salut Clément,

Am 20.12.23 um 20:50 schrieb Clément Lassieur:
> * gnu/packages/gnuzilla.scm (icecat-minimal)[arguments]: Add
> 'libcanberra/lib/gtk-3.0/modules' to LD_LIBRARY_PATH in the 'wrap-program'
> phase.

I assume this fixes some problems with sound themes of Icecat? If I
understand correctly what "libcanberra" is supposed to do...

~Jonathan
Clément Lassieur Dec. 21, 2023, 12:07 p.m. UTC | #2
On Thu, Dec 21, 2023, at 11:23 AM, Jonathan Brielmaier wrote:
> Salut Clément,

Hey Jonathan :)

> Am 20.12.23 um 20:50 schrieb Clément Lassieur:
> > * gnu/packages/gnuzilla.scm (icecat-minimal)[arguments]: Add
> > 'libcanberra/lib/gtk-3.0/modules' to LD_LIBRARY_PATH in the 'wrap-program'
> > phase.
> 
> I assume this fixes some problems with sound themes of Icecat? If I
> understand correctly what "libcanberra" is supposed to do...

It fixes this message on Icecat startup:

Gtk-Message: 13:05:56.635: Failed to load module "canberra-gtk-module"
Gtk-Message: 13:05:56.636: Failed to load module "canberra-gtk-module"

I'll add this to the commit message.
Maxim Cournoyer Jan. 4, 2024, 3:39 a.m. UTC | #3
Hello,

Clément Lassieur <clement@lassieur.org> writes:

> On Thu, Dec 21, 2023, at 11:23 AM, Jonathan Brielmaier wrote:
>> Salut Clément,
>
> Hey Jonathan :)
>
>> Am 20.12.23 um 20:50 schrieb Clément Lassieur:
>> > * gnu/packages/gnuzilla.scm (icecat-minimal)[arguments]: Add
>> > 'libcanberra/lib/gtk-3.0/modules' to LD_LIBRARY_PATH in the 'wrap-program'
>> > phase.
>> 
>> I assume this fixes some problems with sound themes of Icecat? If I
>> understand correctly what "libcanberra" is supposed to do...
>
> It fixes this message on Icecat startup:
>
> Gtk-Message: 13:05:56.635: Failed to load module "canberra-gtk-module"
> Gtk-Message: 13:05:56.636: Failed to load module "canberra-gtk-module"
>
> I'll add this to the commit message.

Ping :-).  LGTM.
Clément Lassieur Jan. 4, 2024, 10:12 a.m. UTC | #4
On Wed, Jan 03 2024, Maxim Cournoyer wrote:

>> It fixes this message on Icecat startup:
>>
>> Gtk-Message: 13:05:56.635: Failed to load module "canberra-gtk-module"
>> Gtk-Message: 13:05:56.636: Failed to load module "canberra-gtk-module"
>>
>> I'll add this to the commit message.
>
> Ping :-).  LGTM.

Pushed, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index b268ae8b7c6d..e0fbabfb68eb 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1092,18 +1092,22 @@  (define-public icecat-minimal
               (let* ((lib (string-append #$output "/lib"))
                      (gtk #$(this-package-input "gtk+"))
                      (gtk-share (string-append gtk "/share"))
-                     (ld-libs '#$(map (lambda (label)
-                                        (file-append (this-package-input label) "/lib"))
-                                      '("libpng-apng"
-                                        "libxscrnsaver"
-                                        "mesa"
-                                        "pciutils"
-                                        "mit-krb5"
-                                        "eudev"
-                                        "pulseaudio"
-                                        ;; For the integration of native notifications
-                                        ;; (same reason as icedove)
-                                        "libnotify"))))
+                     (ld-libs '#$(cons
+                                  (file-append
+                                   (this-package-input "libcanberra")
+                                   "/lib/gtk-3.0/modules")
+                                  (map (lambda (label)
+                                         (file-append (this-package-input label) "/lib"))
+                                       '("libpng-apng"
+                                         "libxscrnsaver"
+                                         "mesa"
+                                         "pciutils"
+                                         "mit-krb5"
+                                         "eudev"
+                                         "pulseaudio"
+                                         ;; For the integration of native notifications
+                                         ;; (same reason as icedove)
+                                         "libnotify")))))
                 (wrap-program (car (find-files lib "^icecat$"))
                   `("XDG_DATA_DIRS" prefix (,gtk-share))
                   ;; The following line is commented out because the icecat