diff mbox series

[bug#50770,core-updates-frozen] Cross-compile more (indirect) GTK+ dependencies

Message ID a6262b0657864473a4e2f62ba074e14ed3fe0bd6.camel@telenet.be
State Accepted
Headers show
Series [bug#50770,core-updates-frozen] Cross-compile more (indirect) GTK+ dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M Sept. 23, 2021, 11:22 p.m. UTC
User: guix
Usertags: cross-compilation

Hi guix,

This small patch series fixes a few easy-to-fix cross-compilation failures
of a few (indirect) dependencies of gtk+.  The first patch can also
be found at <https://issues.guix.gnu.org/50201#69>.

Greetings,
Maxime

Comments

Mathieu Othacehe Sept. 27, 2021, 6:38 p.m. UTC | #1
Hello Maxime,

> This small patch series fixes a few easy-to-fix cross-compilation failures
> of a few (indirect) dependencies of gtk+.  The first patch can also
> be found at <https://issues.guix.gnu.org/50201#69>.

Pushed with edited commit messages.

Thanks,

Mathieu
diff mbox series

Patch

From b68db7b327b4c0f372efbb7fb39791230adb54c9 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Thu, 23 Sep 2021 23:50:28 +0200
Subject: [PATCH 6/6] gnu: gusb: Don't build introspection data when
 cross-compiling.

This fixes a configure error when cross-compilation and doesn't
cause any rebuilds.

* gnu/packages/gnome.scm (gusb)[arguments]<#:configure-flags>:
  Set 'introspection' and 'vapi' to false.
---
 gnu/packages/gnome.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 497713cddc..47eb552603 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6573,7 +6573,14 @@  DAV, and others.")
      `(("glib" ,glib)
        ("libusb" ,libusb)))
     (arguments
-     `(#:tests? #f)) ;libusb fails to initialize.  Wonder what that is.
+     `(#:tests? #f ;libusb fails to initialize.  Wonder what that is.
+       #:configure-flags
+       ,(if (%current-target-system)
+            ;; Introspection data cannot currently be cross-compiled.
+            ''("-Dintrospection=false"
+               ;; Requires introspection data.
+               "-Dvapi=false")
+            ''())))
     (home-page "https://github.com/hughsie/libgusb")
     (synopsis "GLib binding for libusb1")
     (description
-- 
2.33.0