diff mbox series

[bug#65041] gnu: clisp: Add threads support on x84_64-linux.

Message ID a5ff6e10bc72ccb8b046f5c55f7fd6d550605462.1691078405.git.sharlatanus@gmail.com
State New
Headers show
Series [bug#65041] gnu: clisp: Add threads support on x84_64-linux. | expand

Commit Message

Sharlatan Hellseher Aug. 3, 2023, 4:01 p.m. UTC
Guix's build version of CLISP, fails to load bordeaux-threads:

Error while trying to load definition for system bordeaux-threads
      This implementation is unsupported.

This patch adds support for POSIX_THREADS on x86_64-linux
system.

* gnu/packages/lisp.scm (clisp)[arguments]: Add configuration options to
support threads on x86_64-linux system.

Reported and Co-Authored by Andrew Kravchuk <awkravchuk@gmail.com>
---
 gnu/packages/lisp.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)


base-commit: 782cf09b84bc72514e89d783460ea98bc353bf6a

Comments

Sharlatan Hellseher Aug. 26, 2023, 4:14 p.m. UTC | #1
Hi Guix!

A gentle ping on the status of this issue, this patch helps to add
support for thread on x86_64 to CLISP.

Thanks,
Oleg

-- 
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Guillaume Le Vaillant Aug. 28, 2023, 4:23 p.m. UTC | #2
Hi.

As clisp has over 1600 dependent packages, updating it should be done on
a "lisp-team" branch which will be merged into the master branch if all
goes well. However I can't do that right now as I'm on holiday until
next week.


Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

> * gnu/packages/lisp.scm (clisp)[arguments]: Add configuration options to
> support threads on x86_64-linux system.
> [...]
> +                           ,@(if (string-prefix? "x86_64-linux"
> +                                                 (or (%current-system)
> +                                                     (%current-target-system)))
> +                                 '("--enable-portability"
> +                                   "--with-threads=POSIX_THREADS")
> +                                 '())

Does clisp only support threads on x86-64, or could it be enabled for
some other architectures?
diff mbox series

Patch

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 2f4fe6476d..47caa8e389 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -17,7 +17,7 @@ 
 ;;; Copyright © 2019-2023 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
-;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
 ;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2023 Andrew Kravchuk <awkravchuk@gmail.com.
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -380,6 +381,12 @@  (define-public clisp
                                                      (%current-target-system)))
                                  '("CFLAGS=-falign-functions=4")
                                  '())
+                           ,@(if (string-prefix? "x86_64-linux"
+                                                 (or (%current-system)
+                                                     (%current-target-system)))
+                                 '("--enable-portability"
+                                   "--with-threads=POSIX_THREADS")
+                                 '())
                             "--with-dynamic-ffi"
                             "--with-dynamic-modules"
                             "--with-ffcall"