diff mbox series

[bug#63473,3/4] gnu: praat: Add tests to praat.

Message ID a5f4b426e7a9240eb0d1fc4af41395a6c98420f6.1687800992.git.firestone.preston@gmail.com
State New
Headers show
Series [bug#63473,1/4] gnu: praat: Update to 6.1.49. | expand

Commit Message

Preston M. Firestone June 26, 2023, 5:42 p.m. UTC
* gnu/packages/language.scm (praat): Run non-graphical tests.
---
 gnu/packages/language.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index fc33e6f42e..11fc17b427 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -867,13 +867,21 @@  (define-public praat
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags (list (string-append "CC=" ,(cc-for-target)))
-       #:tests? #f                      ; no test target
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'delete-failing-tests
+           (lambda _
+             (delete-file "test/sys/graphicsText.praat")
+             #t))
          (replace 'configure
            (lambda _
              (copy-file "makefiles/makefile.defs.linux.pulse" "makefile.defs")
              #t))
+         (replace 'check
+           (lambda _
+             (invoke "./praat" "--run"
+                     "test/runAllTests_batch.praat")
+             #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))