diff mbox series

[bug#65630] gnu: onnx: Update to 1.14.1

Message ID a5f1270005a0be3f958485d2395f0238a4eeb757.1693413551.git.atai@atai.org
State New
Headers show
Series [bug#65630] gnu: onnx: Update to 1.14.1 | expand

Commit Message

Andy Tai Aug. 30, 2023, 4:40 p.m. UTC
* gnu/packages/machine-learning.scm (onnx): Update to 1.14.1
* gnu/packages/patches/onnx-skip-model-downloads.patch: Adjust to onnx 1.14.1
* gnu/packages/patches/onnx-use-system-googletest.patch: Adjust to onnx 1.14.1
---
 gnu/packages/machine-learning.scm                     | 8 +++++---
 gnu/packages/patches/onnx-skip-model-downloads.patch  | 8 ++++----
 gnu/packages/patches/onnx-use-system-googletest.patch | 8 +++-----
 3 files changed, 12 insertions(+), 12 deletions(-)


base-commit: 74d72046bdc1ed6c859565570d0db58d20c9ddd7

Comments

Sharlatan Hellseher Jan. 4, 2024, 5:11 p.m. UTC | #1
Hi,

name: onnx
version: 1.12.0

Is broken on commit:

guix describe
Generation 498  Jan 04 2024 10:55:58    (current)
  guix 7b0863f
    repository URL: https://git.savannah.gnu.org/git/guix.git
    branch: master
    commit: 7b0863f07a113caef26fea13909bd97d250b629e

phase `make-test-directory-writable' succeeded after 0.0 seconds
starting phase `check'
running "python setup.py" with command "test" and parameters ()
running pytest
/gnu/store/91wasjkmy50p8fq0rf9jby80mnmq1fxr-python-3.10.7/lib/python3.10/site-packages/setuptools/command/easy_install.py:144:
EasyInstallDeprecationWarning: easy_install command is deprecated. Use
build and pip and other standards-based tools.
  warnings.warn(
/gnu/store/91wasjkmy50p8fq0rf9jby80mnmq1fxr-python-3.10.7/lib/python3.10/site-packages/setuptools/command/install.py:34:
SetuptoolsDeprecationWarning: setup.py install is deprecated. Use
build and pip and other standards-based tools.
  warnings.warn(
Searching for protobuf<=3.20.1,>=3.12.2
Reading https://pypi.org/simple/protobuf/
Download error on https://pypi.org/simple/protobuf/: [Errno -3]
Temporary failure in name resolution -- Some packages may not be
found!
Couldn't find index page for 'protobuf' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.org/simple/
Download error on https://pypi.org/simple/: [Errno -3] Temporary
failure in name resolution -- Some packages may not be found!
No local packages or working download links found for protobuf<=3.20.1,>=3.12.2

It would be nice to have it fixed with this update.

Thanks,
Oleg

--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index ca7ca0ff09..267033ef56 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1025,7 +1025,7 @@  (define-public shogun
 (define-public onnx
   (package
     (name "onnx")
-    (version "1.12.0")
+    (version "1.14.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1033,7 +1033,7 @@  (define-public onnx
                     (commit (string-append "v" version))))
               (sha256
                (base32
-                "1g9f1hviksbn7gi6fnd0dsm7nf0w3yia0mjj33d9mggklrl0db6x"))
+                "1lg67z5kzky5qmfcll6dg9pkbdric4d2zwxs89ljc0nyla9rsm35"))
               (file-name (git-file-name name version))
               (patches (search-patches "onnx-use-system-googletest.patch"
                                        "onnx-shared-libraries.patch"
@@ -1059,7 +1059,9 @@  (define-public onnx
                               (string-append "-DCMAKE_INSTALL_RPATH=" out
                                              "/lib")
                               "-DCMAKE_VERBOSE_MAKEFILE=ON"
-
+                              "-DCMAKE_POLICY_DEFAULT_CMP0074=NEW" ; honor packagename_ROOT defines
+                              (string-append "-DGTest_ROOT="
+                              	  (assoc-ref %build-inputs "googletest"))
                               "-DBUILD_SHARED_LIBS=ON"))
 
                       ;; This environment variable is honored by 'setup.py',
diff --git a/gnu/packages/patches/onnx-skip-model-downloads.patch b/gnu/packages/patches/onnx-skip-model-downloads.patch
index 4ab55b4ceb..e96f4cb7d9 100644
--- a/gnu/packages/patches/onnx-skip-model-downloads.patch
+++ b/gnu/packages/patches/onnx-skip-model-downloads.patch
@@ -6,10 +6,10 @@  diff --git a/onnx/backend/test/runner/__init__.py b/onnx/backend/test/runner/__i
 index 049ed57b..f236f1bf 100644
 --- a/onnx/backend/test/runner/__init__.py
 +++ b/onnx/backend/test/runner/__init__.py
-@@ -202,6 +202,7 @@ class Runner(object):
-             print('Start downloading model {} from {}'.format(
-                 model_test.model_name,
-                 model_test.url))
+@@ -227,6 +227,7 @@ class Runner(object):
+             print(
+                 f"Start downloading model {model_test.model_name} from {model_test.url}"
+             )
 +            raise unittest.SkipTest('Skipping download')
              urlretrieve(model_test.url, download_file.name)
              print('Done')
diff --git a/gnu/packages/patches/onnx-use-system-googletest.patch b/gnu/packages/patches/onnx-use-system-googletest.patch
index 5dfcbc6dc3..4279ea37c6 100644
--- a/gnu/packages/patches/onnx-use-system-googletest.patch
+++ b/gnu/packages/patches/onnx-use-system-googletest.patch
@@ -28,21 +28,19 @@  index 0aa9fda2..a573170c 100644
 
  if((ONNX_USE_LITE_PROTO AND TARGET protobuf::libprotobuf-lite) OR ((NOT ONNX_USE_LITE_PROTO) AND TARGET protobuf::libprotobuf))
 diff --git a/cmake/unittest.cmake b/cmake/unittest.cmake
-index e29a93ff..ae146390 100644
+index e71b92a7..30c446ce 100644
 --- a/cmake/unittest.cmake
 +++ b/cmake/unittest.cmake
-@@ -6,8 +6,8 @@ include(${ONNX_ROOT}/cmake/Utils.cmake)
+@@ -7,7 +7,7 @@ include(${ONNX_ROOT}/cmake/Utils.cmake)
 
  find_package(Threads)
 
 -set(${UT_NAME}_libs ${googletest_STATIC_LIBRARIES})
--set(${ONNXIFI_TEST_DRIVER}_libs ${googletest_STATIC_LIBRARIES})
 +set(${UT_NAME}_libs ${GTEST_LIBRARIES})
-+set(${ONNXIFI_TEST_DRIVER}_libs ${GTEST_LIBRARIES})
 
  list(APPEND ${UT_NAME}_libs onnx)
  list(APPEND ${UT_NAME}_libs onnx_proto)
-@@ -31,10 +31,10 @@ function(AddTest)
+@@ -22,10 +22,10 @@ function(AddTest)
    list(REMOVE_DUPLICATES _UT_SOURCES)
 
    add_executable(${_UT_TARGET} ${_UT_SOURCES})