diff mbox series

[bug#71990] gnu: Add emacs-empv.

Message ID a5ea83d2ef14dacce239e98f88ec6be487b4f4ae.1720419862.git.public@thanosapollo.org
State New
Headers show
Series [bug#71990] gnu: Add emacs-empv. | expand

Commit Message

Thanos Apollo July 8, 2024, 6:27 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-empv): New variable.

Change-Id: Ibfb0fca623a536e8db27b15b87e76ef9d7d5a742
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 5217ea6d45bef053844d8360a06252b9436783b3

Comments

Nicolas Goaziou July 8, 2024, 8:02 a.m. UTC | #1
Hello,

Thanos Apollo <public@thanosapollo.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-empv): New variable.

Thank you. Some comments follow.

> +(define-public emacs-empv
> +  (let ((commit "631299ae2a918b4af17ae94eddcde4c9451235bb"))
> +    (package
> +      (name "emacs-empv")
> +      (version "v4.2.0")

Upstream version is confusing. The main file says its 4.3.0, but last
tag, created one day before bumping to 4.3.0, mentions 4.2.0-RC1.

Moreover, commit 631299... does not match a version bump. So, you should
also bind `revision' to, e.g., "0". and use `git-file-name'.

Eventually, you need to remove the "v" from the version string. It
belongs to the tag, not the version.

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/isamert/empv.el")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> +           "0njqzri2qvpsdbkrkr1lidg2zc2742nzapwgdjaf5ms3rl8kc898"))))
> +      (build-system emacs-build-system)
> +      (propagated-inputs
> +       (list emacs-compat
> +	     emacs-s))

You can write propagated inputs on a single line.

  (propagated-inputs (list emacs-compat emacs-s))

> +      (home-page "https://github.com/isamert/empv.el")
> +      (synopsis "An Emacs media player, media library manager, radio player, YouTube frontend ")

Please remove the article "An" and the trailing white space.

> +      (description
> +       "An Emacs media player, based on mpv.  More precisely this package
> +provides somewhat comprehensive interface to mpv with bunch of
> +convenient functionality like an embedded radio manager, YouTube
> +interface, local music/video library manager etc.")
> +      (license license:gpl3+))))

Description should consist of complete sentences. I suggest something
like:

  "This package is an Emacs player, based on MPV.  More precisely, it
  [...], local music and video library manager, etc."

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c82e264930..0bb115ee42 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3730,6 +3730,34 @@  (define-public emacs-emprise
 Selectrum.")
     (license license:gpl3+)))
 
+(define-public emacs-empv
+  (let ((commit "631299ae2a918b4af17ae94eddcde4c9451235bb"))
+    (package
+      (name "emacs-empv")
+      (version "v4.2.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/isamert/empv.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0njqzri2qvpsdbkrkr1lidg2zc2742nzapwgdjaf5ms3rl8kc898"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-compat
+	     emacs-s))
+      (home-page "https://github.com/isamert/empv.el")
+      (synopsis "An Emacs media player, media library manager, radio player, YouTube frontend ")
+      (description
+       "An Emacs media player, based on mpv.  More precisely this package
+provides somewhat comprehensive interface to mpv with bunch of
+convenient functionality like an embedded radio manager, YouTube
+interface, local music/video library manager etc.")
+      (license license:gpl3+))))
+
 (define-public emacs-marginalia-emprise
   (package
     (name "emacs-marginalia-emprise")