[bug#78170] gnu: Add python-kconfiglib.

Message ID a5832dba5dd9787b4c43cb54c12a37ab7e9fef36.1746066513.git.z572@z572.online
State New
Headers
Series [bug#78170] gnu: Add python-kconfiglib. |

Commit Message

Zheng Junjie May 1, 2025, 2:28 a.m. UTC
  * gnu/packages/linux.scm (python-kconfiglib): New variable.

Change-Id: I09235059a14e2ed94f476e1709074e508c5e3964
---
 gnu/packages/linux.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)


base-commit: d505cb960fd1e670be9a66d9fdbad94bc49e891d
  

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b4adf0c2b43..bed3d6c4781 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -11767,6 +11767,25 @@  (define-public hid-wiimote-plus
     (home-page "https://github.com/dkosmari/hid-wiimote-plus")
     (license license:gpl2+)))
 
+(define-public python-kconfiglib
+  (package
+    (name "python-kconfiglib")
+    (version "14.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "kconfiglib" version))
+       (sha256
+        (base32 "0g690bk789hsry34y4ahvly5c8w8imca90ss4njfqf7m2qicrlmy"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-setuptools python-wheel))
+    (inputs (list `(,python "tk")))
+    (home-page "https://github.com/ulfalizer/Kconfiglib")
+    (synopsis "A flexible Python Kconfig implementation")
+    (description
+     "This package provides a flexible Python Kconfig implementation.")
+    (license license:isc)))
+
 (define-public python-evemu
   (package
     (name "python-evemu")