diff mbox series

[bug#59264] gnu: Add emacs-ef-themes.

Message ID a582e4306795bb1740bc2038bd18dff8de27a3ef.1668445413.git.avityazev@posteo.org
State New
Headers show
Series [bug#59264] gnu: Add emacs-ef-themes. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev Nov. 14, 2022, 5:03 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ef-themes): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou Nov. 17, 2022, 11:51 a.m. UTC | #1
Hello,

Aleksandr Vityazev <avityazev@posteo.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-ef-themes): New variable.

Applied with the following changes.

> +     "The ef-themes are a collection of light and dark themes for GNU Emacs

ef-themes -> Ef themes

> +whose goal is to provide colorful (\"pretty\") yet legible options
> for users

I removed ("pretty").

> +who want something with a bit more flair than the modus-themes.")

modus-themes -> Modus themes.

Thank you.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c260ee85c5..e3e960c445 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5172,6 +5172,29 @@  (define-public emacs-ecukes
 intended to be.")
     (license license:gpl3+)))
 
+(define-public emacs-ef-themes
+  (package
+    (name "emacs-ef-themes")
+    (version "0.9.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~protesilaos/ef-themes")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1h1xlcbcay8wlmhzv7b5h6vrvwdwkzc171aa0rfja2xds4ry9k0m"))))
+    (build-system emacs-build-system)
+    (home-page "https://git.sr.ht/~protesilaos/ef-themes")
+    (synopsis "Colorful and legible themes")
+    (description
+     "The ef-themes are a collection of light and dark themes for GNU Emacs
+whose goal is to provide colorful (\"pretty\") yet legible options for users
+who want something with a bit more flair than the modus-themes.")
+    (license license:gpl3+)))
+
 (define-public emacs-espuds
   (package
     (name "emacs-espuds")