diff mbox series

[bug#43348] Profanity

Message ID a560bb06-7d8a-5933-9f58-1a4e1f1b810e@disroot.org
State Accepted
Headers show
Series [bug#43348] Profanity | expand

Commit Message

Raghav Gururajan Sept. 11, 2020, 7:52 p.m. UTC
Hello Guix!

Please find the attached patch to make changed to Profanity.

Regards,
RG.

Comments

Danny Milosavljevic Sept. 12, 2020, 12:51 a.m. UTC | #1
Hi RG,

please, for existing packages, try to be as clear as possible in the commit
messages in what is changed (only one related set of things should be changed
per commit).

In this case the commit confounds things:

* Changing the build-system reference.  This does not enable runtime
features--which is what the commit message's topic stated that the commit does.
* Changing the autoconf method.  This does not enable runtime features--which
is what the commit message's topic stated that the commit does.
* Adding Python as a NATIVE input.  What is that about?  Is profanity using
a Python program as a compiler only?
* I think that moving those native-inputs to inputs, while correct, does not
enable runtime features--which is what the commit message's topic stated that
the commit does.
* Please use two spaces (after the period) in order to separate sentences.
* Moving blocks around makes review much harder for users.

The goal of those commit messages, and of the commit rules, is to make it
easy for each user to see at a glance what topic each commit changes.
diff mbox series

Patch

From ab2019fae29bc45a47e2e8a91bdbd25e53b16969 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 11 Sep 2020 15:40:52 -0400
Subject: [PATCH 4/4] gnu: profanity: Revise package definition.

* gnu/packages/messaging.scm (profanity): Add missing features.
[build-system]: Change from gnu to glib-or-gtk.
[arguments]<#:configure-flags>[--enable-python-plugins]: New flag.
[--enable-plugins]: New flag.
[--enable-icons-and-clipboard]: New flag.
[--enable-icons]: Remove flag.
[native-inputs]: Add python-wrapper. Remove autoconf-archive. Move
gtk+-2, libnotify and libsignal-protocol-c to ...
[inputs]: ... here. Add gtk+ and libstrophe.
---
 gnu/packages/messaging.scm | 58 ++++++++++++++++++++++----------------
 1 file changed, 33 insertions(+), 25 deletions(-)

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index ae9f73dcb7..843bd44e84 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1779,43 +1779,51 @@  are both supported).")
   (package
     (name "profanity")
     (version "0.9.5")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://profanity-im.github.io/profanity-"
-                                  version ".tar.gz"))
-              (sha256
-               (base32
-                "00j9l9v62rz9hprgiy1vrz8v3v59ph18h8kskqxr31fgqvjv5xr3"))))
-    (build-system gnu-build-system)
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://profanity-im.github.io/profanity-"
+                       version ".tar.gz"))
+       (sha256
+        (base32
+         "00j9l9v62rz9hprgiy1vrz8v3v59ph18h8kskqxr31fgqvjv5xr3"))))
+    (build-system glib-or-gtk-build-system)
     (arguments
-     '(#:configure-flags
-       (list "--enable-c-plugins"
-             "--enable-otr"
-             "--enable-omemo"
-             "--enable-pgp"
-             "--enable-icons"
-             "--enable-notifications")))
+     `(#:configure-flags
+       (list
+        "--enable-notifications"
+        "--enable-python-plugins"
+        "--enable-c-plugins"
+        "--enable-plugins"
+        "--enable-otr"
+        "--enable-pgp"
+        "--enable-omemo"
+        "--enable-icons-and-clipboard")))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("cmocka" ,cmocka)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python-wrapper)))
     (inputs
      `(("curl" ,curl)
        ("expat" ,expat)
        ("glib" ,glib)
        ("gpgme" ,gpgme)
+       ("gcrypt" ,libgcrypt)
+       ("gtk+" ,gtk+)
+       ("gtk+-2" ,gtk+-2)
        ("libmesode" ,libmesode)
+       ("libnotify" ,libnotify)
+       ("libsignal" ,libsignal-protocol-c)
+       ("libstrophe" ,libstrophe)
        ("libotr" ,libotr)
        ("ncurses" ,ncurses)
        ("openssl" ,openssl)
        ("readline" ,readline)
        ("sqlite" ,sqlite)))
-    (native-inputs
-     `(("autoconf" ,autoconf)
-       ("autoconf-archive" ,autoconf-archive)
-       ("automake" ,automake)
-       ("cmocka" ,cmocka)
-       ("gtk+" ,gtk+-2)
-       ("libnotify" ,libnotify)
-       ("libtool" ,libtool)
-       ("libsignal-protocol-c" ,libsignal-protocol-c)
-       ("pkg-config" ,pkg-config)))
     (synopsis "Console-based XMPP client")
     (description "Profanity is a console based XMPP client written in C
 using ncurses and libmesode, inspired by Irssi.")
-- 
2.28.0