From ab2019fae29bc45a47e2e8a91bdbd25e53b16969 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 11 Sep 2020 15:40:52 -0400
Subject: [PATCH 4/4] gnu: profanity: Revise package definition.
* gnu/packages/messaging.scm (profanity): Add missing features.
[build-system]: Change from gnu to glib-or-gtk.
[arguments]<#:configure-flags>[--enable-python-plugins]: New flag.
[--enable-plugins]: New flag.
[--enable-icons-and-clipboard]: New flag.
[--enable-icons]: Remove flag.
[native-inputs]: Add python-wrapper. Remove autoconf-archive. Move
gtk+-2, libnotify and libsignal-protocol-c to ...
[inputs]: ... here. Add gtk+ and libstrophe.
---
gnu/packages/messaging.scm | 58 ++++++++++++++++++++++----------------
1 file changed, 33 insertions(+), 25 deletions(-)
@@ -1779,43 +1779,51 @@ are both supported).")
(package
(name "profanity")
(version "0.9.5")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://profanity-im.github.io/profanity-"
- version ".tar.gz"))
- (sha256
- (base32
- "00j9l9v62rz9hprgiy1vrz8v3v59ph18h8kskqxr31fgqvjv5xr3"))))
- (build-system gnu-build-system)
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://profanity-im.github.io/profanity-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00j9l9v62rz9hprgiy1vrz8v3v59ph18h8kskqxr31fgqvjv5xr3"))))
+ (build-system glib-or-gtk-build-system)
(arguments
- '(#:configure-flags
- (list "--enable-c-plugins"
- "--enable-otr"
- "--enable-omemo"
- "--enable-pgp"
- "--enable-icons"
- "--enable-notifications")))
+ `(#:configure-flags
+ (list
+ "--enable-notifications"
+ "--enable-python-plugins"
+ "--enable-c-plugins"
+ "--enable-plugins"
+ "--enable-otr"
+ "--enable-pgp"
+ "--enable-omemo"
+ "--enable-icons-and-clipboard")))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("cmocka" ,cmocka)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)))
(inputs
`(("curl" ,curl)
("expat" ,expat)
("glib" ,glib)
("gpgme" ,gpgme)
+ ("gcrypt" ,libgcrypt)
+ ("gtk+" ,gtk+)
+ ("gtk+-2" ,gtk+-2)
("libmesode" ,libmesode)
+ ("libnotify" ,libnotify)
+ ("libsignal" ,libsignal-protocol-c)
+ ("libstrophe" ,libstrophe)
("libotr" ,libotr)
("ncurses" ,ncurses)
("openssl" ,openssl)
("readline" ,readline)
("sqlite" ,sqlite)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("autoconf-archive" ,autoconf-archive)
- ("automake" ,automake)
- ("cmocka" ,cmocka)
- ("gtk+" ,gtk+-2)
- ("libnotify" ,libnotify)
- ("libtool" ,libtool)
- ("libsignal-protocol-c" ,libsignal-protocol-c)
- ("pkg-config" ,pkg-config)))
(synopsis "Console-based XMPP client")
(description "Profanity is a console based XMPP client written in C
using ncurses and libmesode, inspired by Irssi.")
--
2.28.0