diff mbox series

[bug#38059,1/2] gnu: Add python-socksipychain.

Message ID a533db4a-12b0-4ba0-ae34-e39673942968@www.fastmail.com
State Accepted
Headers show
Series gnu: Add pagekite. | expand

Commit Message

Alex Griffin Nov. 4, 2019, 2:47 p.m. UTC

Comments

Ludovic Courtès Nov. 10, 2019, 11:21 a.m. UTC | #1
Hi Alex,

"Alex Griffin" <a@ajgrf.com> skribis:

> From 4b3e2d8a6e5897659ebc06bc809277ee6fc29121 Mon Sep 17 00:00:00 2001
> From: Alex Griffin <a@ajgrf.com>
> Date: Sat, 2 Nov 2019 13:43:21 -0500
> Subject: [PATCH 1/2] gnu: Add python-socksipychain.
>
> * gnu/packages/python-xyz.scm (python-socksipychain, python2-socksipychain):
> New variables.

LGTM!  It would be great to avoid the python2 variant (Python 2.x is a
few months away from EOL!), but let’s discuss it in the next patch.

Thanks,
Ludo’.
diff mbox series

Patch

From 4b3e2d8a6e5897659ebc06bc809277ee6fc29121 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sat, 2 Nov 2019 13:43:21 -0500
Subject: [PATCH 1/2] gnu: Add python-socksipychain.

* gnu/packages/python-xyz.scm (python-socksipychain, python2-socksipychain):
New variables.
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 29362e2f2b..7b05718192 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4454,6 +4454,35 @@  as the original project seems to have been abandoned circa 2007.")
 (define-public python2-socksipy-branch
   (package-with-python2 python-socksipy-branch))
 
+(define-public python-socksipychain
+  (package
+    (name "python-socksipychain")
+    (version "2.0.15")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pagekite/PySocksipyChain.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1pkljnh9hfwla8sg7mil4f9zrnsqj0dbhr3crxjw3k8dnjz70dvk"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ; Tests try to access the network.
+    (home-page "http://pagekite.net/wiki/Floss/PySocksipyChain/")
+    (synopsis "Python SOCKS module with chained proxies support")
+    (description
+     "SocksiPyChain is a modified version of the SocksiPy SOCKS module, which
+adds support for arbitrary chaining of proxy servers and various modes of
+TLS/SSL encryption.  It was developed for use in PageKite, and also includes
+a simple netcat replacement with chaining support.")
+    (license license:bsd-3)))
+
+(define-public python2-socksipychain
+  (package-with-python2 python-socksipychain))
+
 (define-public python-pycodestyle
   (package
     (name "python-pycodestyle")
-- 
2.23.0