diff mbox series

[bug#67123] gnu: Add pass-coffin

Message ID a4f0c32dbef8aed66617b9cdd7ea47d5a3114a63.1699728082.git.christian.miller@dadoes.de
State New
Headers show
Series [bug#67123] gnu: Add pass-coffin | expand

Commit Message

Christian Miller Nov. 11, 2023, 6:41 p.m. UTC
* gnu/packages/password-utils.scm (pass-coffin): New variable.

Change-Id: I2fdf6c755b9b75780c5a3c0304e5b961a15640a4
---
 gnu/packages/password-utils.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: af6105afc67a15a491a0a4fd18a28c9f801a0b94

Comments

Steve George Feb. 24, 2024, 8:39 a.m. UTC | #1
Review by Steve George: 
  * submission: checked commit format, synopsis and commit
  * submission: license, patch applies cleanly
  * functionality: test installed, guix lint is clean
  * code: checked style
  * added: Reviewed-by commit trailer
  * re-roll to trigger QA build

  * Question for committer: this is an add-on to password-store and can't be
    used without it. Should password-store be a propagated-input?


Christian Miller via Guix-patches via (1):
  gnu: Add pass-coffin

 gnu/packages/password-utils.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: e7990b12170eec0c35541196f948be26a9e4a519
Clément Lassieur Feb. 24, 2024, 10:23 a.m. UTC | #2
On Sat, Feb 24 2024, Steve George wrote:

> Review by Steve George: 
>   * submission: checked commit format, synopsis and commit
>   * submission: license, patch applies cleanly
>   * functionality: test installed, guix lint is clean
>   * code: checked style
>   * added: Reviewed-by commit trailer
>   * re-roll to trigger QA build
>
>   * Question for committer: this is an add-on to password-store and can't be
>     used without it. Should password-store be a propagated-input?

I don't think so.  See emacs for example.  That would make it harder to
use another version of password-store.

> Christian Miller via Guix-patches via (1):
>   gnu: Add pass-coffin
>
>  gnu/packages/password-utils.scm | 32 ++++++++++++++++++++++++++++++++
>  1 file changed, 32 insertions(+)
>
>
> base-commit: e7990b12170eec0c35541196f948be26a9e4a519
Andreas Enge Feb. 26, 2024, 3:51 p.m. UTC | #3
Hello,

like Clément, I would say we should not propagate password-store.
It would also create a weird situation when people install password-store
with one revision of Guix, and add this extension from a different revision.
More generally, password-store in a profile and from the propagated input
could clash, and it would be surprising if installing an extension swaps
the main program under your feet.

Applied, thanks for the patch and the review!

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 385bd64985..f9767b91af 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -39,6 +39,7 @@ 
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2023 Christian Miller <christian.miller@dadoes.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1567,6 +1568,37 @@  (define-public pass-tomb
 pass-tomb to automatically close your store after a given time.")
     (license license:gpl3+)))
 
+(define-public pass-coffin
+  (package
+    (name "pass-coffin")
+    (version "1.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ayushnix/pass-coffin")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1486ikwsdjsj74qf949vk47r8mfp2mbbdc3scs8786nnnkhzc89n"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f ;No tests
+      #:make-flags #~(list (string-append "PREFIX="
+                                          #$output)
+                           (string-append "BASHCOMPDIR="
+                                          #$output "/etc/bash_completion.d"))
+      #:phases #~(modify-phases %standard-phases
+                   (delete 'configure))))
+    (inputs (list password-store tar))
+    (home-page "https://github.com/ayushnix/pass-coffin")
+    (synopsis "Pass extension to keep the tree of passwords encrypted")
+    (description
+     "Pass-coffin is a pass extension that hides the password store
+data inside a GPG encrypted file, which we'll call a coffin.")
+    (license license:gpl3)))
+
 (define-public xkcdpass
   (package
     (name "xkcdpass")