diff mbox series

[bug#40779] Acknowledgement (Submission of CRAN Package Descriptions r-dcv r-stam r-grouped r-sgloptim r-awsmethods r-aws r-tea r-rcdd r-rxnat)

Message ID a4db09ce-b572-993f-9862-02e1fa39c30d@riseup.net
State Accepted
Headers show
Series [bug#40779] Acknowledgement (Submission of CRAN Package Descriptions r-dcv r-stam r-grouped r-sgloptim r-awsmethods r-aws r-tea r-rcdd r-rxnat) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Naga Malleswari April 22, 2020, 8:04 p.m. UTC
Submitting Patches for CRAN PACKAGES

r-dcv

r-stam

r-grouped

r-sgloptim

r-awsmethods

r-aws

r-tea

r-rcdd

r-rxnat

I have done these patches earlier while practice. Submitting them to the
guix system.

On 23/04/20 1:11 am, GNU bug Tracking System wrote:
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 40779@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>

Comments

Ricardo Wurmus April 23, 2020, 3:11 p.m. UTC | #1
Hi NagaMalli,

thank you for your patches!

Please run “./pre-inst-env guix lint” on each of the packages.  Please
pay special attention to the description and synopsis fields.  The
descriptions often contain sentence fragments – we prefer to have
complete sentences.  Make sure that there are two spaces after end of
sentence periods — not zero spaces and not just one space either.

For the synopses please only capitalize proper names (like “Bayes”) and
the first word.  CRAN packages use capitalization for all words, so we
need to change that.

Please also run etc/indent-code.el to fix the indentation.  The importer
doesn’t do the right thing because it doesn’t know about our
conventions.

Could you please send updated patches as a reply to this email thread?

Thank you!

--
Ricardo
diff mbox series

Patch

From de01c0bceaee3062d32fdca209bc35280695d1cd Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Thu, 23 Apr 2020 01:13:12 +0530
Subject: [PATCH 1/9] gnu: Add r-tea.

* gnu/packages/cran.scm (r-tea): New variable.
---
 gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70cb7cc700..ac55916964 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21162,3 +21162,32 @@  evaluated interactively.")
 Bayes factors, posterior model probabilities, and normalizing constants in
 general, via different versions of bridge sampling.")
     (license license:gpl2+)))
+
+(define-public r-tea
+  (package
+    (name "r-tea")
+    (version "1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "tea" version))
+        (sha256
+          (base32
+            "0ql7lrxk0ihm49kqsvz79ig8i54rwiy9nxav4v9hy72j9kj5bgjn"))))
+    (properties
+     `((upstream-name . "tea")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-matrix" ,r-matrix)))
+    (home-page "https://cran.r-project.org/web/packages/tea")
+    (synopsis "Threshold Estimation Approaches")
+    (description
+      "Different approaches for selecting the threshold in generalized Pareto
+distributions.Most of them are based on minimizing the AMSE-criterion or
+atleast by reducing the bias of the assumed GPD-model. Others are
+heuristically motivated by searching for stable sample paths, i.e.  a
+nearly constant region of the tail index estimator with respect to k,
+which is the number of data in the tail. The third class is motivated by
+graphical inspection.In addition, a sequential testing procedure for
+GPD-GoF-tests is also implemented here.")
+    (license license:gpl3)))
-- 
2.25.1