[bug#78475,2/3] gnu: Add perl-test-xpath.

Message ID a4b4f715b41ad777ae1c90044d14a47d17411090.1747534033.git.gemmaro.dev@gmail.com
State New
Headers
Series gnu: Add perl-pod-site |

Commit Message

gemmaro May 18, 2025, 2:13 a.m. UTC
  * gnu/packages/perl-check.scm (perl-test-xpath): New variable.

Change-Id: I2cd4d70401bc8cad1727ab10739e0be609c18314
---
 gnu/packages/perl-check.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
  

Patch

diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 5de8a76973..7de087c8b0 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -39,6 +39,7 @@  (define-module (gnu packages perl-check)
   #:use-module (gnu packages)
   #:use-module (gnu packages valgrind)
   #:use-module (gnu packages web)
+  #:use-module (gnu packages xml)
   #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -1730,6 +1731,26 @@  (define-public perl-test-writevariants
 generation of tests in nested combinations of contexts.")
     (license perl-license)))  ; see LICENSE
 
+(define-public perl-test-xpath
+  (package
+    (name "perl-test-xpath")
+    (version "0.20")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/M/MA/MANWAR/Test-XPath-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "0f90i66i8flk1fj8grzp5lvvhxlrjj4gdg5md6brrba6f4g63anz"))))
+    (build-system perl-build-system)
+    (propagated-inputs (list perl-html-selector-xpath perl-xml-libxml))
+    (home-page "https://metacpan.org/release/Test-XPath")
+    (synopsis "Test XML and HTML content and structure with XPath expressions")
+    (description
+     "This Perl testing library focuses on testing and working with
+XPath expressions, most likely in the context of XML document processing.")
+    (license perl-license)))
+
 (define-public perl-test-yaml
   (package
     (name "perl-test-yaml")