diff mbox series

[bug#69273] gnu: python-ega-download-client: Update to 5.1.0.

Message ID a48bda549640e1910f508611a76462bb50cc2553.1708357342.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#69273] gnu: python-ega-download-client: Update to 5.1.0. | expand

Commit Message

nafkhamdc Feb. 19, 2024, 3:42 p.m. UTC
* gnu/packages/bioinformatics.scm (python-ega-download-client): Update to 5.1.0.

Change-Id: I010c3a0e7cb69184b72e8b13bad04ff2fd364f5a
---
 gnu/packages/bioinformatics.scm | 26 ++++++++++++++------------
 1 file changed, 14 insertions(+), 12 deletions(-)


base-commit: 052ef145215d45e1fe0e179df3b8c9626e021c2b

Comments

Andreas Enge March 7, 2024, 6:37 p.m. UTC | #1
The patch does not update the package, we are already at this version.
Also it does not actually apply.

Actually it looks as if the tests to be disabled by this patch have
already been disabled in a different commit.

So I am closing this bug, thanks!

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 85507b6c15..00a20aa4fc 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2541,18 +2541,20 @@  (define-public python-ega-download-client
     (build-system pyproject-build-system)
     (arguments
      (list
-      #:test-flags
-      '(list "-k"
-             ;; These tests fail because they require internet access.
-             (string-append "not test_download.py"
-                            " and not test_htsget.py"
-                            " and not test_commands.py"))
-      #:phases
-      '(modify-phases %standard-phases
-         (add-after 'unpack 'relax-requirements
-           (lambda _
-             (substitute* "setup.py"
-               (("==") ">=")))))))
+      #:test-flags '(list "-k"
+                          ;; These tests fail because they require internet access.
+                          (string-append "not test_download.py"
+                                         " and not test_htsget.py"
+                                         " and not test_commands.py"
+                          ;; The following 2 tests are failing with MaxRetriesReachedError
+                                         " and not test_download_file.py"
+                                         " and not test_download_file.py"))
+      #:phases '(modify-phases %standard-phases
+                  (add-after 'unpack 'relax-requirements
+                    (lambda _
+                      (substitute* "setup.py"
+                        (("==")
+                         ">=")))))))
     (propagated-inputs (list python-htsget python-psutil python-requests
                              python-tqdm python-urllib3))
     (native-inputs (list python-coverage python-pytest python-pyfakefs