diff mbox series

[bug#64909,vREVISION] gnu: godot: Use system brotli.

Message ID a44e64b2866e47a2912e33c05e1be400fb899fd1.1690853354.git.takev@disroot.org
State New
Headers show
Series [bug#64909,vREVISION] gnu: godot: Use system brotli. | expand

Commit Message

TakeV Aug. 1, 2023, 1:29 a.m. UTC
Updated the commit.

* gnu/packages/game-development.scm (godot)[source]: Do not preserve brotli.
[arguments]<#:scons-flags>: Add “builtin_brotli=no”.
[inputs]: Add brotli.
---
 gnu/packages/game-development.scm | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)


base-commit: 39fbc041f92489ec30075a85937c8a38723752dc
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index f4b1a1e1e3..5771b7530f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2017,10 +2017,6 @@  (define-public godot
                               "assimp"
                               "astcenc"
                               "basis_universal"
-                              ;; TODO: Can unbundle once
-                              ;; <https://github.com/godotengine/godot/pull/79101>
-                              ;; is merged
-                              "brotli"
                               ;; Godot needs ca-certificates.crt, but that is
                               ;; not available in build environment
                               "certs"
@@ -2067,6 +2063,7 @@  (define-public godot
                         "use_volk=no"
                         ;; Avoid using many of the bundled libs.
                         ;; Note: These options can be found in the SConstruct file.
+                        "builtin_brotli=no"
                         "builtin_embree=no"
                         "builtin_enet=no"
                         "builtin_freetype=no"
@@ -2193,6 +2190,7 @@  (define-public godot
      (list pkg-config))
     (inputs
      (list alsa-lib
+           brotli
            dbus
            embree
            enet