diff mbox series

[bug#37886] gnu: Add ipcalc.

Message ID a44c1913-9030-1c1b-879c-981708b6bdc1@danielschaefer.me
State Accepted
Headers show
Series [bug#37886] gnu: Add ipcalc. | expand

Commit Message

Daniel Schäfer Oct. 23, 2019, 1:44 p.m. UTC
Hi,
here's my first patch to guix - please let me know whether everything's okay.
It adds the ipcalc package which can calculate IP ranges. Example:

$ /gnu/store/7jw45m8d1hcaihnr7978qqg1didl048a-ipcalc-0.41/bin/ipcalc 192.168.0.1/24
Address:   192.168.0.1          11000000.10101000.00000000. 00000001
Netmask:   255.255.255.0 = 24   11111111.11111111.11111111. 00000000
Wildcard:  0.0.0.255            00000000.00000000.00000000. 11111111
=>
Network:   192.168.0.0/24       11000000.10101000.00000000. 00000000
HostMin:   192.168.0.1          11000000.10101000.00000000. 00000001
HostMax:   192.168.0.254        11000000.10101000.00000000. 11111110
Broadcast: 192.168.0.255        11000000.10101000.00000000. 11111111
Hosts/Net: 254                   Class C, Private Internet


* gnu/packages/ipcalc.scm (ipcalc): New file.
---
 gnu/packages/ipcalc.scm | 61 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 61 insertions(+)
 create mode 100644 gnu/packages/ipcalc.scm

Comments

Mathieu Othacehe Oct. 24, 2019, 3:12 p.m. UTC | #1
Hello Daniel,

> here's my first patch to guix - please let me know whether everything's okay.
> It adds the ipcalc package which can calculate IP ranges. Example:

Welcome to Guix :) This first patch looks fine, I just have two remarks.

> new file mode 100644
> index 0000000000..5f83389b25
> --- /dev/null
> +++ b/gnu/packages/ipcalc.scm

I think you can use the existing networking.scm for this tool.

> +    (description "ipcalc takes an IP address and netmask and calculates the
> +                 resulting broadcast, network, Cisco wildcard mask, and host
> +                 range.  By giving a second netmask, you can design subnets and
> +                 supernets.  It is also intended to be a teaching tool and
> +                 presents the subnetting results as easy-to-understand binary
> +                 values.")

The indentation is not correct here. You can use M-q if you are using
emacs or indent.el script otherwise (see:
https://guix.gnu.org/manual/en/html_node/Formatting-Code.html).

Can you please send an updated patch?

Thanks,

Mathieu
Ludovic Courtès Nov. 25, 2019, 11:42 p.m. UTC | #2
Hello Daniel,

Did you have a chance to look into the suggestions Mathieu made?
See <https://issues.guix.gnu.org/issue/37886>.

Thanks in advance!  :-)

Ludo’.

Mathieu Othacehe <m.othacehe@gmail.com> skribis:

> Hello Daniel,
>
>> here's my first patch to guix - please let me know whether everything's okay.
>> It adds the ipcalc package which can calculate IP ranges. Example:
>
> Welcome to Guix :) This first patch looks fine, I just have two remarks.
>
>> new file mode 100644
>> index 0000000000..5f83389b25
>> --- /dev/null
>> +++ b/gnu/packages/ipcalc.scm
>
> I think you can use the existing networking.scm for this tool.
>
>> +    (description "ipcalc takes an IP address and netmask and calculates the
>> +                 resulting broadcast, network, Cisco wildcard mask, and host
>> +                 range.  By giving a second netmask, you can design subnets and
>> +                 supernets.  It is also intended to be a teaching tool and
>> +                 presents the subnetting results as easy-to-understand binary
>> +                 values.")
>
> The indentation is not correct here. You can use M-q if you are using
> emacs or indent.el script otherwise (see:
> https://guix.gnu.org/manual/en/html_node/Formatting-Code.html).
>
> Can you please send an updated patch?
>
> Thanks,
>
> Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/ipcalc.scm b/gnu/packages/ipcalc.scm
new file mode 100644
index 0000000000..5f83389b25
--- /dev/null
+++ b/gnu/packages/ipcalc.scm
@@ -0,0 +1,61 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Daniel Schaefer <git@danielschaefer.me>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ipcalc)
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages)
+  #:use-module (guix download)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix build-system gnu))
+
+(define-public ipcalc
+  (package
+    (name "ipcalc")
+    (version "0.41")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://jodies.de/ipcalc-archive/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "12if9sm8h2ac0pgwkw835cgyqjxm6h27k4kfn2vfas9krrqwbafx"))))
+    (inputs `(("perl" ,perl)))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f  ; No test suite
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'build)
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out-bin (string-append
+                             (assoc-ref outputs "out")
+                             "/bin")))
+               (install-file "ipcalc" out-bin)
+               #t))))))
+    (synopsis "Simple IP network calculator")
+    (description "ipcalc takes an IP address and netmask and calculates the
+                 resulting broadcast, network, Cisco wildcard mask, and host
+                 range.  By giving a second netmask, you can design subnets and
+                 supernets.  It is also intended to be a teaching tool and
+                 presents the subnetting results as easy-to-understand binary
+                 values.")
+    (home-page "http://jodies.de/ipcalc")
+    (license gpl2+)))