diff mbox series

[bug#67582,gnome-team,2/4] gnu: Add python-dbus-python.

Message ID a42fa1fc21dcb1548d41816ac3190b029e252702.1701513359.git.liliana.prikler@gmail.com
State New
Headers show
Series Update python-dbusmock | expand

Commit Message

Liliana Marie Prikler Dec. 1, 2023, 11:09 p.m. UTC
* gnu/packages/python-xyz.scm (python-dbus-python): New variable.

Change-Id: I7d9ba58466e8a07119073209e47814fc9fc573cb
---
 gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Maxim Cournoyer Dec. 3, 2023, 5:19 p.m. UTC | #1
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/python-xyz.scm (python-dbus-python): New variable.

[...]

> +(define-public python-dbus-python
> +  (package
> +  (name "python-dbus-python")
> +  (version "1.3.2")
> +  (source
> +   (origin
> +     (method url-fetch)
> +     (uri (pypi-uri "dbus-python" version))
> +     (sha256
> +      (base32 "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
> +  (build-system pyproject-build-system)
> +  (arguments
> +   (list #:phases #~(modify-phases %standard-phases
> +                      (add-after 'unpack 'patch-requirements
> +                        (lambda _
> +                          (substitute* (list "pyproject.toml" "setup.py")
> +                            (("'(ninja|patchelf)',?") ""))
> +                          (substitute* "setup.cfg"
> +                            (("(ninja|patchelf)") "")))))))
> +  (inputs (list dbus glib))
> +  (propagated-inputs (list python-pygobject))
> +  (native-inputs (list pkg-config
> +                       python-meson-python
> +                       meson ninja patchelf
> +                       python-sphinx python-sphinx-rtd-theme
> +                       python-tappy
> +                       python-wheel))

Is this 'guix style' produced?  The convention is to use:

(native-inputs
 (list one
       two
       ...))

When there are more than 5 inputs (or if they don't fit on a single
line).

Otherwise,

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Liliana Marie Prikler Dec. 3, 2023, 6:41 p.m. UTC | #2
Am Sonntag, dem 03.12.2023 um 12:19 -0500 schrieb Maxim Cournoyer:
> Hello,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > * gnu/packages/python-xyz.scm (python-dbus-python): New variable.
> 
> [...]
> 
> > +(define-public python-dbus-python
> > +  (package
> > +  (name "python-dbus-python")
> > +  (version "1.3.2")
> > +  (source
> > +   (origin
> > +     (method url-fetch)
> > +     (uri (pypi-uri "dbus-python" version))
> > +     (sha256
> > +      (base32
> > "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
> > +  (build-system pyproject-build-system)
> > +  (arguments
> > +   (list #:phases #~(modify-phases %standard-phases
> > +                      (add-after 'unpack 'patch-requirements
> > +                        (lambda _
> > +                          (substitute* (list "pyproject.toml"
> > "setup.py")
> > +                            (("'(ninja|patchelf)',?") ""))
> > +                          (substitute* "setup.cfg"
> > +                            (("(ninja|patchelf)") "")))))))
> > +  (inputs (list dbus glib))
> > +  (propagated-inputs (list python-pygobject))
> > +  (native-inputs (list pkg-config
> > +                       python-meson-python
> > +                       meson ninja patchelf
> > +                       python-sphinx python-sphinx-rtd-theme
> > +                       python-tappy
> > +                       python-wheel))
> 
> Is this 'guix style' produced?  The convention is to use:
> 
> (native-inputs
>  (list one
>        two
>        ...))
> 
> When there are more than 5 inputs (or if they don't fit on a single
> line).
I manually grouped them by theme.

Cheers
Maxim Cournoyer Dec. 3, 2023, 7:06 p.m. UTC | #3
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Sonntag, dem 03.12.2023 um 12:19 -0500 schrieb Maxim Cournoyer:
>> Hello,
>> 
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>> 
>> > * gnu/packages/python-xyz.scm (python-dbus-python): New variable.
>> 
>> [...]
>> 
>> > +(define-public python-dbus-python
>> > +  (package
>> > +  (name "python-dbus-python")
>> > +  (version "1.3.2")
>> > +  (source
>> > +   (origin
>> > +     (method url-fetch)
>> > +     (uri (pypi-uri "dbus-python" version))
>> > +     (sha256
>> > +      (base32
>> > "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
>> > +  (build-system pyproject-build-system)
>> > +  (arguments
>> > +   (list #:phases #~(modify-phases %standard-phases
>> > +                      (add-after 'unpack 'patch-requirements
>> > +                        (lambda _
>> > +                          (substitute* (list "pyproject.toml"
>> > "setup.py")
>> > +                            (("'(ninja|patchelf)',?") ""))
>> > +                          (substitute* "setup.cfg"
>> > +                            (("(ninja|patchelf)") "")))))))
>> > +  (inputs (list dbus glib))
>> > +  (propagated-inputs (list python-pygobject))
>> > +  (native-inputs (list pkg-config
>> > +                       python-meson-python
>> > +                       meson ninja patchelf
>> > +                       python-sphinx python-sphinx-rtd-theme
>> > +                       python-tappy
>> > +                       python-wheel))
>> 
>> Is this 'guix style' produced?  The convention is to use:
>> 
>> (native-inputs
>>  (list one
>>        two
>>        ...))
>> 
>> When there are more than 5 inputs (or if they don't fit on a single
>> line).
> I manually grouped them by theme.

I see.  I'd still prefer the conventional sorted flat list, because the
next person touching it probably won't notice and break that logic.

-- 
Thanks,
Maxim
Liliana Marie Prikler Dec. 19, 2023, 10:54 p.m. UTC | #4
Am Sonntag, dem 03.12.2023 um 14:06 -0500 schrieb Maxim Cournoyer:
> Hi,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > Am Sonntag, dem 03.12.2023 um 12:19 -0500 schrieb Maxim Cournoyer:
> > > Hello,
> > > 
> > > Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> > > 
> > > > * gnu/packages/python-xyz.scm (python-dbus-python): New
> > > > variable.
> > > 
> > > [...]
> > > 
> > > > +(define-public python-dbus-python
> > > > +  (package
> > > > +  (name "python-dbus-python")
> > > > +  (version "1.3.2")
> > > > +  (source
> > > > +   (origin
> > > > +     (method url-fetch)
> > > > +     (uri (pypi-uri "dbus-python" version))
> > > > +     (sha256
> > > > +      (base32
> > > > "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
> > > > +  (build-system pyproject-build-system)
> > > > +  (arguments
> > > > +   (list #:phases #~(modify-phases %standard-phases
> > > > +                      (add-after 'unpack 'patch-requirements
> > > > +                        (lambda _
> > > > +                          (substitute* (list "pyproject.toml"
> > > > "setup.py")
> > > > +                            (("'(ninja|patchelf)',?") ""))
> > > > +                          (substitute* "setup.cfg"
> > > > +                            (("(ninja|patchelf)") "")))))))
> > > > +  (inputs (list dbus glib))
> > > > +  (propagated-inputs (list python-pygobject))
> > > > +  (native-inputs (list pkg-config
> > > > +                       python-meson-python
> > > > +                       meson ninja patchelf
> > > > +                       python-sphinx python-sphinx-rtd-theme
> > > > +                       python-tappy
> > > > +                       python-wheel))
> > > 
> > > Is this 'guix style' produced?  The convention is to use:
> > > 
> > > (native-inputs
> > >  (list one
> > >        two
> > >        ...))
> > > 
> > > When there are more than 5 inputs (or if they don't fit on a
> > > single line).
> > I manually grouped them by theme.
> 
> I see.  I'd still prefer the conventional sorted flat list, because
> the next person touching it probably won't notice and break that
> logic.
We can still break it when the next person touches it, so that's fine
by me :)

Pushed, along with the rest.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3e406cc677..3e23311b80 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -173,6 +173,7 @@  (define-module (gnu packages python-xyz)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bdw-gc)
+  #:use-module (gnu packages build-tools)
   #:use-module (gnu packages check)
   #:use-module (gnu packages cmake)
   #:use-module (gnu packages compression)
@@ -186,6 +187,7 @@  (define-module (gnu packages python-xyz)
   #:use-module (gnu packages djvu)
   #:use-module (gnu packages docker)
   #:use-module (gnu packages documentation)
+  #:use-module (gnu packages elf)
   #:use-module (gnu packages enchant)
   #:use-module (gnu packages file)
   #:use-module (gnu packages fonts)
@@ -27300,6 +27302,39 @@  (define-public python-pykwalify
 for YAML and JSON.")
     (license license:expat)))
 
+(define-public python-dbus-python
+  (package
+  (name "python-dbus-python")
+  (version "1.3.2")
+  (source
+   (origin
+     (method url-fetch)
+     (uri (pypi-uri "dbus-python" version))
+     (sha256
+      (base32 "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
+  (build-system pyproject-build-system)
+  (arguments
+   (list #:phases #~(modify-phases %standard-phases
+                      (add-after 'unpack 'patch-requirements
+                        (lambda _
+                          (substitute* (list "pyproject.toml" "setup.py")
+                            (("'(ninja|patchelf)',?") ""))
+                          (substitute* "setup.cfg"
+                            (("(ninja|patchelf)") "")))))))
+  (inputs (list dbus glib))
+  (propagated-inputs (list python-pygobject))
+  (native-inputs (list pkg-config
+                       python-meson-python
+                       meson ninja patchelf
+                       python-sphinx python-sphinx-rtd-theme
+                       python-tappy
+                       python-wheel))
+  (home-page "https://dbus.freedesktop.org/doc/dbus-python/")
+  (synopsis "Python bindings for libdbus")
+  (description "This package provides Python bindings to libdbus, the
+reference implementation of the D-Bus protocol.")
+  (license license:expat)))
+
 (define-public python-dbusmock
   (package
     (name "python-dbusmock")