diff mbox series

[bug#65477,v2,2/2] gnu: Add emacs-slite.

Message ID a420186bcb0d5137bfa3cee1f2aae4a2e62eded8.1695846794.git.mail@ykonai.net
State New
Headers show
Series [bug#65477,v2,1/2] gnu: Add cl-slite. | expand

Commit Message

ykonai Sept. 27, 2023, 8:33 p.m. UTC
* gnu/packages/lisp-xyz.scm (emacs-slite): New variable.

The package is within lisp-xyz.scm due to inheriting from sbcl-slite (as it is
really one project, with an CL part and an Emacs part).
---
 gnu/packages/lisp-xyz.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 6f9a942a30..5cd9a61680 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -72,6 +72,7 @@  (define-module (gnu packages lisp-xyz)
   #:use-module (guix build-system asdf)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
+  #:use-module (guix build-system emacs)
   #:use-module (gnu packages audio)
   #:use-module (gnu packages base)
   #:use-module (gnu packages c)
@@ -27361,6 +27362,21 @@  (define-public cl-slite
 (define-public ecl-slite
   (sbcl-package->ecl-package sbcl-slite))
 
+(define-public emacs-slite
+  (package
+    (inherit sbcl-slite)
+    (name "emacs-slite")
+    (build-system emacs-build-system)
+    (synopsis "SLIme-based TEst runner for FiveAM and Parachute Tests")
+    (description
+     "Slite interactively runs your Common Lisp tests (currently only FiveAM
+and Parachute are supported). It allows you to see the summary of test
+failures, jump to test definitions, rerun tests with debugger all from inside
+Emacs.
+
+In order to work, this also requires the slite Common Lisp system to be
+present. See the code@{*cl-slite packages}.")))
+
 (define-public sbcl-parseq
   (package
     (name "sbcl-parseq")