diff mbox series

[bug#40537] gnu: Add bchoppr.

Message ID a401109b6c714c4aae69ad3ed54a6607672fae1c.camel@zrythm.org
State Accepted
Headers show
Series [bug#40537] gnu: Add bchoppr. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou April 11, 2020, 4:15 p.m. UTC
Please use this patch instead for bchoppr (updated version to 1.4.2).
The author fixed a bug that was causing a crash in Zrythm.

Thanks,
Alex
diff mbox series

Patch

From cb765aeba81d505a103203d6bfdf917fdf0b5bab Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 10 Apr 2020 13:34:17 +0100
Subject: [PATCH 1/3] gnu: Add bchoppr.

* gnu/packages/music.scm (bchoppr): new variable.
---
 gnu/packages/music.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5257d9463a..fb8c0445bb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5422,3 +5422,25 @@  plugin and a standalone JACK application.")
   offers an LV2 version ported by moddevices.")
       (home-page "http://tap-plugins.sourceforge.net/")
       (license license:gpl2))))
+
+(define-public bchoppr
+  (package
+    (inherit bsequencer)
+    (name "bchoppr")
+    (version "1.4.2")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/sjaehn/BChoppr.git")
+               (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "1ympx0kyn3mkb23xgd44rlrf4qnngnlkmikz9syhayklgax7ijgm"))))
+    (synopsis "Audio stream-chopping LV2 plugin")
+    (description "B.Choppr cuts the audio input stream into a repeated
+sequence of up to 16 chops.  Each chop can be leveled up or down (gating).
+B.Choppr is the successor of B.Slizr.")
+    (home-page "https://github.com/sjaehn/BChoppr")
+    (license license:gpl3+)))
-- 
2.26.0