diff mbox series

[bug#64503] gnu: python-pygments: Update to 2.15.1.

Message ID a3fbc81cd84383483da8aee1e52a6dcbcec8863e.1688678327.git.rekado@elephly.net
State New
Headers show
Series [bug#64503] gnu: python-pygments: Update to 2.15.1. | expand

Commit Message

Ricardo Wurmus July 6, 2023, 9:18 p.m. UTC
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
[build-system]: Use pyproject-build-system.
[arguments]: Run tests.
[native-inputs]: Add python-pytest.
---
 gnu/packages/python-xyz.scm | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)


base-commit: 2426e51688d479042ea115a634c6be2d8b9f3b99
prerequisite-patch-id: 64bdaf1b46e713c11e7e3befc50968710d721da1
prerequisite-patch-id: 33eb796cc51e4372cab09fce61b1c4da73c5884d

Comments

Lars-Dominik Braun July 9, 2023, 5:05 p.m. UTC | #1
Hi,

> * gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
> [build-system]: Use pyproject-build-system.
> [arguments]: Run tests.
> [native-inputs]: Add python-pytest.

LGTM. How do you want to push this, since it affects alot of
packages? python-team?

Lars
Ricardo Wurmus July 9, 2023, 7:53 p.m. UTC | #2
Lars-Dominik Braun <lars@6xq.net> writes:

>> * gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
>> [build-system]: Use pyproject-build-system.
>> [arguments]: Run tests.
>> [native-inputs]: Add python-pytest.
>
> LGTM. How do you want to push this, since it affects alot of
> packages? python-team?

Either that or piggy-backing on the tex-team branch that’s about ready
to be built these days.
Lars-Dominik Braun July 10, 2023, 6:17 a.m. UTC | #3
Hi,

> Either that or piggy-backing on the tex-team branch that’s about ready
> to be built these days.

tex-team will probably be faster. python-team is not ready yet,
unfortunately :(

Lars
Ricardo Wurmus July 18, 2023, 8:05 a.m. UTC | #4
Lars-Dominik Braun <lars@6xq.net> writes:

>> Either that or piggy-backing on the tex-team branch that’s about ready
>> to be built these days.
>
> tex-team will probably be faster. python-team is not ready yet,
> unfortunately :(

After discussing with ngz, we think it’s better to keep this out of
tex-team, because there’s a chance of unforeseen breakage.  May I push
this to the python-team branch?
Lars-Dominik Braun July 18, 2023, 8:41 a.m. UTC | #5
Hey Ricardo,

> After discussing with ngz, we think it’s better to keep this out of
> tex-team, because there’s a chance of unforeseen breakage.  May I push
> this to the python-team branch?

sure. Please create a new branch, since python-team does not exist
yet. I’ll also push some things I’m working on later and #64573
would probably be a good candidate for python-team too.

Cheers,
Lars
Ricardo Wurmus July 18, 2023, 9:39 a.m. UTC | #6
Hi Lars,

>> After discussing with ngz, we think it’s better to keep this out of
>> tex-team, because there’s a chance of unforeseen breakage.  May I push
>> this to the python-team branch?
>
> sure. Please create a new branch, since python-team does not exist
> yet. I’ll also push some things I’m working on later and #64573
> would probably be a good candidate for python-team too.

Okay, I’ve pushed this and #64573 to a new python-team branch and added
a specification on ci.guix.gnu.org to build the branch for x86_64.
jgart July 19, 2023, 11:49 p.m. UTC | #7
Thanks Ricardo,

I'll take a closer look at the Python branch soon. What is the timeline for when the Python branch is expected to be merged into master?

Have we agreed on that timeline somewhere and I missed it?

all best,

jgart
Ricardo Wurmus July 20, 2023, 6:39 a.m. UTC | #8
"jgart" <jgart@dismail.de> writes:

> I'll take a closer look at the Python branch soon. What is the
> timeline for when the Python branch is expected to be merged into
> master?
>
> Have we agreed on that timeline somewhere and I missed it?

No, there’s no plan yet.

I see that the pygments upgrade broke sphinx, so that would be the next
thing to fix.
Ricardo Wurmus Feb. 27, 2024, 10:18 a.m. UTC | #9
This is on python-team and sphinx has been upgraded too.  Closing.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a89f25b5b6..89a75556bd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5913,18 +5913,23 @@  (define-public python-doc8
 (define-public python-pygments
   (package
     (name "python-pygments")
-    (version "2.12.0")
+    (version "2.15.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Pygments" version))
        (sha256
         (base32
-         "1sr6iqh21xi6p8aba4wa9pqfhjbbpcvn9jcsx0ggy4lniw8idcay"))))
-    (build-system python-build-system)
+         "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+    (build-system pyproject-build-system)
     (arguments
-     ;; FIXME: Tests require sphinx, which depends on this.
-     '(#:tests? #f))
+     (list
+      #:test-flags
+      ;; Some tests require sphinx, which depends on this, so we only run
+      ;; basic tests.
+      '(list "--ignore-glob=tests/*/*")))
+    (native-inputs
+     (list python-pytest))
     (home-page "https://pygments.org/")
     (synopsis "Syntax highlighting")
     (description