diff mbox series

[bug#63854,core-updates,v4,2/2] gnu: po4a: Enable SGML format.

Message ID a3f711c9a42a5fa7253f656feca2d653aabd00fa.1690037161.git.gemmaro.dev@gmail.com
State New
Headers show
Series gnu: po4a: Enable SGML format. | expand

Commit Message

gemmaro July 22, 2023, 2:56 p.m. UTC
* gnu/packages/gettext.scm (po4a): Enable SGML format.
[arguments]<phases>: Remove disable-failing-tests phase.
[native-inputs]: Add docbook-sgml-4.1.
[inputs]: Add opensp.
---
 gnu/packages/gettext.scm | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index b3dd844147..ca52f912e7 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -11,7 +11,7 @@ 
 ;;; Copyright © 2019 Miguel <rosen644835@gmail.com>
 ;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2020 EuAndreh <eu@euandre.org>
-;;; Copyright © 2022 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2022, 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2023 Maxim Cournoyer maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -276,10 +276,6 @@  (define-public po4a
                             (wrap-program file
                               `("PERL5LIB" ":" prefix (,path))))
                           (find-files bin "\\.*$")))))
-          (add-before 'check 'disable-failing-tests
-            (lambda _
-              ;; FIXME: fails despite of importing SGMLS
-              (delete-file "t/fmt-sgml.t")))
           #$@(if (system-hurd?)
                  #~((add-after 'unpack 'skip-tests/hurd
                       (lambda _
@@ -291,14 +287,16 @@  (define-public po4a
      (list gettext-minimal
            perl-module-build
            docbook-xsl
-           libxml2
+           libxml2 ;for SGML_CATALOG_FILES
            libxslt
            ;; For tests.
+           docbook-sgml-4.1
            docbook-xml-4.1.2
            perl-test-pod
            (texlive-updmap.cfg)))
     (inputs
      (list bash-minimal
+           opensp
            perl-gettext
            perl-pod-parser
            perl-sgmls