[bug#76491] gnu: emacs-popper: Update to 0.4.8.
Commit Message
The previous Guix version, 0.45, was propagated from an upstream typo
for 0.4.5. This likely prevented ‘guix refresh’ from updating the
package.
* gnu/packages/emacs-xyz.scm (emacs-popper): Update to 0.4.8.
Change-Id: I7ec81b81c90bb6e05cf764d01caf948427e922b7
---
gnu/packages/emacs-xyz.scm | 39 ++++++++++++++++++--------------------
1 file changed, 18 insertions(+), 21 deletions(-)
base-commit: 6cd8c5849666af658c4b2e3bd4436e1a77691e41
Comments
Hi Liam,
Pushed as 256bee7d0b.
Thanks,
-- Ian
@@ -11488,28 +11488,25 @@ (define-public emacs-popup-kill-ring
(license license:gpl3+))))
(define-public emacs-popper
- ;; No tagged release upstream for version 0.45. The commit below matches
- ;; version bump.
- (let ((commit "851d83882192ac9599ac5b053614a42d683b3fab"))
- (package
- (name "emacs-popper")
- (version "0.45")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/karthink/popper")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0pk5wzqlz7n6v8rb1957i3ql0wjx578l68a3rp2m9pxr7a8a03h4"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/karthink/popper")
- (synopsis "Emacs minor-mode to summon and dismiss buffers easily")
- (description
- "Popper is a minor-mode to tame the flood of ephemeral
+ (package
+ (name "emacs-popper")
+ (version "0.4.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/karthink/popper")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1x1nnc0li8jd609lnmmax2hl69wmbq84c6b2mdg0wb7zf0k29lba"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/karthink/popper")
+ (synopsis "Emacs minor-mode to summon and dismiss buffers easily")
+ (description
+ "Popper is a minor-mode to tame the flood of ephemeral
windows Emacs produces, while still keeping them within arm’s reach.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-pydoc
;; https://github.com/statmobile/pydoc/issues/31