diff mbox series

[bug#48660] gnu: emacs-shell-command+: Use Git repo instead of ELPA URL.

Message ID a3925071e6fd24cadcc25c1936cdf4459fd4fecf.1621979103.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#48660] gnu: emacs-shell-command+: Use Git repo instead of ELPA URL. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen May 25, 2021, 9:48 p.m. UTC
* emacs-xyz.scm (emacs-shell-command+)[source]: Use Git repository instead of
  the unstable ELPA URL.
---
Use the Git repo until the ELPA reproducibility issue[1] has been fixed.

[1]: https://issues.guix.gnu.org/46849

 gnu/packages/emacs-xyz.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)


base-commit: 0ffac75ece4f22a8595e19b8a375791e87d365aa

Comments

Nicolas Goaziou May 26, 2021, 12:52 p.m. UTC | #1
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

> * emacs-xyz.scm (emacs-shell-command+)[source]: Use Git repository instead of
>   the unstable ELPA URL.
> ---
> Use the Git repo until the ELPA reproducibility issue[1] has been fixed.
>
> [1]: https://issues.guix.gnu.org/46849

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 886320cc34..a7c8799bf5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27353,11 +27353,12 @@  Features:
     (name "emacs-shell-command+")
     (version "2.2.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://elpa.gnu.org/packages/"
-                                  "shell-command+-" version ".tar"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~zge/bang")
+                    (commit version)))
               (sha256
-               (base32 "1ms2xk7xfgd3ngwm90hnmlxwpvyb167bislc2wr3ilfrirbbw476"))))
+               (base32 "1micvz6smhjma7qbka8h3w0crb3sgrxf9lz2548iqfgww50gb0lj"))))
     (build-system emacs-build-system)
     (home-page "http://elpa.gnu.org/packages/shell-command+.html")
     (synopsis "Extended Emacs @code{shell-command}")