diff mbox series

[bug#69867,2/2] gnu: magic-wormhole: Update to 0.13.0.

Message ID a341dbebca429164aa81bb8552528dc1ba15bda9.1710960666.git.normally_js@posteo.net
State New
Headers show
Series gnu: magic-wormhole: Update to 0.13.0. | expand

Commit Message

normally_js March 20, 2024, 6:55 p.m. UTC
* gnu/packages/magic-wormhole.scm (magic-wormhole): Update to 0.13.0.
[native-inputs]: Add python-noiseprotocol to make tests pass.

Change-Id: I59008f27081efcc3b558dad59bef6ebdc9b34f38
---
 gnu/packages/magic-wormhole.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/magic-wormhole.scm b/gnu/packages/magic-wormhole.scm
index 86a8013aa1..f9ccf8c1d3 100644
--- a/gnu/packages/magic-wormhole.scm
+++ b/gnu/packages/magic-wormhole.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2024 normally_js <normally_js@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -106,14 +107,14 @@  (define-public magic-wormhole-transit-relay
 (define-public magic-wormhole
   (package
     (name "magic-wormhole")
-    (version "0.12.0")
+    (version "0.13.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "magic-wormhole" version))
         (sha256
          (base32
-          "0q41j99718y7m95zg1vaybnsp31lp6lhyqkbv4yqz5ys6jixh3qv"))))
+          "05hm5pnrxli69a28h3pbgx6s6pwy8279l506kha7y3i7hs1dcfxc"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -128,6 +129,7 @@  (define-public magic-wormhole
              #t)))))
     (native-inputs
      (list python-mock
+           python-noiseprotocol
            ;; XXX These are required for the test suite but end up being referenced
            ;; by the built package.
            ;; https://bugs.gnu.org/25235